Acknowledgements

Quake Wiki: HomePage Acknowledgements

We'd like to thank...

  • JakFrost for the Console Command site http://www.planetquake.com/console/, which was used as a reference during the creation the Console Commands section.
  • Uwe Girlich for the Quake Demospecs, which we didn't really use, but still: http://www.planetquake.com/demospecs/
  • Olivier Montanuy for the Quake Specs, which served as inspiration.
  • David "DarkGrue" Hesprich for the QuakeC Reference manual which served as inspiration (mostly because of all the mistakes it has...)
  • id Software for Quake, QuakeC and the all the sources to go with.
  • Ender and QuakeSrc for hosting and setting this site up.
  • Maddes and Quake Info Pool for many years of just being cool.
  • Adiemus for the site design
View Source of this page Last edited on November 29, 2002 PageHistory Info


Adding Pages

Quake Wiki: HomePage Adding Pages

To add a new page to Wiki, all you have to do is come up with a meaningful title, capitalize all the words and StringThemTogetherLikeThis ?. Wiki automagically recognizes it as a hyperlink. Alternatively, you can put anything into square brackets ?.

Then you can go ahead and ClickTheQuestionMark ? at the end of your new hyperlink, and the Wiki will give you a window for making the new page.

If you wish to add documents with complex markup to the Wiki, you might be better off providing a URL to it than trying to add the text of the document here, like so:

PhpWiki project homepage: http://phpwiki.sourceforge.net/

The Wiki does not support HTML tags (see TextFormattingRules). <tags>They will just render like text.</tags> Wiki is meant to be as simple as possible to encourage use.

Note that there is a feature that your system administrator can enable to allow embedded HTML, but there are security risks involved.

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Add Logical Jumps

Quake Wiki: HomePage Add Logical Jumps

/Oo - Add logical jumps

This is a speed optimization that adds opcodes to attempt to skip past long logical calculations in conditionals. Because this adds opcodes it is not a space optimization. This optimization will confuse decompilers and may result in "indentation structure corrupt" errors when trying to decompile.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Ad Quedit

Quake Wiki: HomePage Ad Quedit

Link to download: http://www.quadmire.com/files/adquedit.zip

AdQuedit is a useful utility for Quake editing. To quote the README:

"AdQuedit: The Quake Workstation is my addition to Quake editing development. The main purpose of this program is to supply an easy, flexible, and useable means to manipulate the many file formats that Quake has. Features include replacing textures in BSP files, editing entity lists, changing model skins, creating sprites, making mip textures, and extensive WAD editing, and much more. And all cholesterol free!"

View Source of this page Last edited on January 7, 2003 PageHistory Info


Akuma

Quake Wiki: HomePage Akuma

"Is there no-one worth fighting?"

Akuma's Evile Empire

View Source of this page Last edited on November 15, 2002 PageHistory Info


All Pages

Quake Wiki: HomePage All Pages

Pages in this wiki (619 total):

  • !
  • !=
  • &&
  • +
  • +command
  • +mlook
  • -
  • -allow360
  • -basedir
  • -cachedir
  • -conheight
  • -conwidth
  • -current
  • -dedicated
  • -game
  • -height
  • -hipnotic
  • -ip
  • -listen
  • -mlook
  • -nocdaudio
  • -particles
  • -rogue
  • -width
  • -window
  • .blocked
  • .button0
  • .classname
  • .colormap
  • .fixangle
  • .health
  • .model
  • .movetype
  • .netname
  • .nextthink
  • .origin
  • .owner
  • .skin
  • .solid
  • .team
  • .think
  • .touch
  • .use
  • .v_angle
  • .velocity
  • .weaponframe
  • <
  • <=
  • =
  • ==
  • >
  • >=
  • Acknowledgements
  • AdQuedit
  • Add Logical Jumps
  • AddingPages
  • Akuma
  • AllPages
  • AllUsers
  • Ammo Boxes
  • Arrays
  • Available Cvars
  • Axe
  • BackLinks
  • Biosuit
  • Builtin Function List
  • Burning Tutorials
  • CalendarPlugin
  • Camper
  • CategoryCategory
  • CategoryHomePages
  • CheapAlert
  • CheapHack
  • Chthon
  • ClientConnect
  • ClientKill
  • Command Line Parameters
  • Console Commands
  • Console Variables
  • DCQuake
  • DCQuake Downloads
  • DCQuake Mod List
  • DCQuake Modding Information
  • DaZ
  • DarkPlaces
  • Darkplaces
  • Death Knight
  • DebugInfo
  • Demo Tools
  • Dont do list
  • Double-Barrelled Shotgun
  • Downloads
  • DrLabman
  • Dreamcast Quake
  • EBSP
  • ENV Heighfields
  • EditText
  • Eliminate Constant Names and Defs
  • Eliminate Duplicate Defs
  • Eliminate Local Names
  • Eliminate Source Code Filenames
  • Eliminate Temporary Variables
  • Eliminate Uneeded Function Names
  • Enforcer
  • Engine Tutorials
  • Engines
  • Enhanced Engine Features
  • Entity Guide
  • Errorabove
  • ExternalSearch
  • FALSE
  • FL_MONSTER
  • FL_ONGROUND
  • Farc
  • Fiend
  • FileUpload
  • FileUploadSubmit
  • FindPage
  • Flatten Constant Arithmetic
  • Fniggium
  • Free Resources
  • FrikQCC
  • FrikaC
  • FrikaC's Mods and Sods
  • FuhQuake
  • FullRecentChanges
  • FullTextSearch
  • FuzzyPages
  • GLQuake
  • Gameplay Tips
  • Gleeb
  • Glossary
  • GoodStyle
  • Grenade Launcher
  • Grunt
  • Hash Lookup in CopyString
  • Hazards
  • Health
  • Hell Knight
  • HomePage
  • HomePage/Talk
  • HowToUseWiki
  • HudModels
  • IceDagger
  • ImUnreal
  • Inside3D
  • Installing Addons
  • InterWiki
  • InterWikiMap
  • Items
  • Jaws/Talk
  • John Romero
  • Knight
  • Lava
  • LikePages
  • LinkIcons
  • Links
  • LocalMenu
  • LocalMenus
  • Lord Xanathar
  • MDQNet
  • MOVETYPE_BOUNCE
  • MOVETYPE_BOUNCEMISSILE
  • MOVETYPE_FLY
  • MOVETYPE_FLYMISSILE
  • MOVETYPE_NOCLIP
  • MOVETYPE_NONE
  • MOVETYPE_PUSH
  • MOVETYPE_STEP
  • MOVETYPE_TOSS
  • MOVETYPE_WALK
  • MSG_ALL
  • MSG_BROADCAST
  • MSG_INIT
  • MSG_ONE
  • Maddes
  • MagicPhpWikiURLs
  • Map List
  • Mapping Links
  • Mapping Tools
  • Mapping Tutorials
  • Mega-Health
  • MilkShape 3D
  • Mod List
  • Modding Tools
  • Monsters
  • MoreAboutMechanics
  • MostPopular
  • Movie List
  • MrGleeb
  • Multi Grenades
  • Multiplayer Guide
  • Multiplayer Maps
  • Multiplication
  • Murphy's Law
  • Nailgun
  • Nehahra
  • NetQuake
  • NewMarkupTestPage
  • Non Vector Parms
  • NormalQuake
  • Ogre
  • OldStyleTablePlugin
  • Optimizations
  • OrphanedPages
  • Other Features
  • PageGroupTest
  • PageGroupTestFour
  • PageGroupTestOne
  • PageGroupTestThree
  • PageGroupTestTwo
  • PageHistory
  • PageInfo
  • PakScape
  • Pentagram of Protection
  • Perforator
  • PgsrcTranslation
  • PhpWiki
  • PhpWikiAdministration
  • PhpWikiAdministration/Remove
  • PhpWikiDocumentation
  • PlanetQuake
  • PlayerPostThink
  • PlayerPreThink
  • Port Differences
  • Prydon Gate
  • PutClientInServer
  • Q100
  • Q101
  • Q102
  • Q103
  • Q104
  • Q105
  • Q106
  • Q107
  • Q108
  • Q109
  • Q110
  • Q111
  • Q112
  • Q113
  • Q114
  • Q115
  • Q116
  • Q117
  • Q118
  • Q119
  • Q120
  • Q121
  • Q122
  • Q123
  • Q124
  • Q125
  • Q126
  • Q127
  • Q128
  • Q201
  • Q202
  • Q203
  • Q204
  • Q205
  • Q206
  • Q207
  • Q208
  • Q301
  • Q302
  • Q500
  • Q502
  • Q505
  • Q548
  • Q550
  • Q551
  • Q552
  • Q617
  • QCC
  • QCCX
  • QCCX Manual
  • QCVM
  • QE5
  • QMB
  • QSG Extensions
  • QuArK
  • Quad Damage
  • Quake
  • Quake Error Guide
  • Quake File Formats
  • Quake Font
  • Quake II
  • Quake Network Messages
  • Quake Palette
  • Quake tools
  • QuakeC
  • QuakeC Basics
  • QuakeC Code Optimizations
  • QuakeC Keywords
  • QuakeC Operators
  • QuakeC Tips
  • QuakeC Tutorials
  • QuakeC Types
  • QuakeDC
  • QuakeDC Downloads
  • QuakeDC Mod List
  • QuakeDC Modding Information
  • QuakeEd
  • QuakeSrc
  • QuakeWorld
  • RandomPage
  • RecentChanges
  • RecentEdits
  • RecentVisitors
  • Recycle temps
  • RegisterUser
  • RegisterUserSubmit
  • ReleaseNotes
  • Renegade
  • Rick
  • Ring of Shadows
  • Rocket Launcher
  • Roids
  • Rotfish
  • Rottweiler
  • SOLID_BBOX
  • SOLID_BSP
  • SOLID_NOT
  • SOLID_SLIDEBOX
  • SOLID_TRIGGER
  • SVC_BAD
  • SVC_CENTERPRINT
  • SVC_DISCONNECT
  • SVC_FINALE
  • SVC_FOUNDSECRET
  • SVC_INTERMISSION
  • SVC_KILLEDMONSTER
  • SVC_NOP
  • SVC_PARTICLE
  • SVC_PRINT
  • SVC_SELLSCREEN
  • SVC_SETANGLE
  • SVC_SETVIEW
  • SVC_SOUND
  • SVC_TIME
  • SVC_UPDATECOLORS
  • SVC_UPDATENAME
  • SVC_UPDATESTAT
  • SVC_VERSION
  • SandBox
  • Scrag
  • SeienAbunae
  • Shambler
  • Shorten ifs
  • Shotgun
  • Shub-Niggurath
  • SideBar
  • SinglePlayer Quake Engines
  • Singleplayer Guide
  • Singleplayer Maps
  • Site Help
  • Slime
  • Slipgate
  • Spawn
  • Star Wars Dogfighter
  • StartFrame
  • StaticFiend
  • Statistics and Info
  • SteveWainstead
  • Super Nailgun
  • System Fields
  • System Globals
  • TRUE
  • TeamFortress
  • Tei
  • Telejano
  • TestPage
  • TexMex
  • TextFormattingRules
  • Textures
  • The Fall of CDRom.com
  • The best of 2002 Screenshots, by Tei
  • The best of 2003 Screenshots, by Tei
  • Thunderbolt
  • Tips to fix warnings and errors in a decompiled source
  • TitleSearch
  • TomazQuake
  • TranscludePlugin
  • Use Linked Lists For Added Speed
  • UserPreferences
  • Valve Software
  • Versions & Changelog
  • Vile
  • Vore
  • W_LoadWadFile : couldn't load gfx.wad
  • WabiSabi
  • Wally
  • WantedPages
  • WarQraft
  • WarQraft/Talk
  • Warning and Error Guide
  • Weapons
  • WikiPlugin
  • WikiWikiWeb
  • WinQuake
  • WorldCraft
  • WriteAngle
  • WriteByte
  • WriteChar
  • WriteLong
  • WriteString
  • Zombie
  • _cl_color
  • _cl_name
  • _config_com_baud
  • _config_com_irq
  • _config_com_modem
  • _config_com_port
  • _config_modem_clear
  • _config_modem_dialtype
  • _config_modem_hangup
  • _config_modem_init
  • _snd_mixahead
  • _windowed_mouse
  • acous
  • ambient_level
  • bacon
  • bf
  • bgmvolume
  • bigmap
  • bigmap/talk
  • boomstick
  • bprint
  • cdrom.com
  • centerprint
  • centerview
  • changelevel
  • chasin
  • checkclient
  • cl_bob
  • clear
  • cobalt
  • color
  • constant
  • coop
  • coop global
  • crosshair
  • cvar
  • cvarstring
  • deathmatch
  • deathmatch global
  • diGGer
  • dm-e1m2
  • dm2
  • dm3
  • dm4
  • dot product
  • drogg
  • e1m1
  • e1m7
  • e2m3
  • echo
  • edict
  • else
  • end
  • end_sys_globals
  • engine
  • entity
  • escape characters
  • evile
  • fastqcc
  • fields
  • find
  • float
  • float type
  • floor
  • fly
  • force_centerview
  • force_retouch
  • found_secrets
  • fov
  • frametime
  • frightfan
  • ftos
  • functions
  • games.lst
  • gl_clear
  • gl_flashblend
  • gl_keeptjunctions
  • gl_polyblend
  • gl_texsort
  • gl_ztrick
  • god
  • hexed
  • hipnotic
  • id Software
  • id1
  • if
  • immediate
  • impulse
  • info_player_start
  • int
  • int type
  • javascript:alert('oops')
  • js
  • killed_monsters
  • lg
  • local
  • localcmd
  • main
  • makestatic
  • makevectors
  • map
  • mapname
  • modification
  • monster_ogre_marksman
  • monster_wizard
  • movetogoal
  • msg_entity
  • name
  • nextent
  • noclip
  • other
  • parm1
  • parm10
  • parm11
  • parm12
  • parm13
  • parm14
  • parm15
  • parm16
  • parm2
  • parm3
  • parm4
  • parm5
  • parm6
  • parm7
  • parm8
  • parm9
  • particle
  • pencechp
  • pointfile
  • precache_file
  • precache_model
  • qME
  • quit
  • r_aliastransadj
  • r_aliastransbase
  • r_fullbright
  • random
  • remove
  • restart
  • return
  • rocketman
  • saved1
  • saved2
  • saved3
  • saved4
  • savedgamecfg
  • scr_centertime
  • screenshot
  • self
  • serverflags
  • setmodel
  • setorigin
  • showturtle
  • single player
  • skill
  • spawn
  • sprint
  • start
  • state macro
  • static entities
  • status
  • stef.feola
  • string
  • string type
  • stuffcmd
  • sv_aim
  • sv_gravity
  • sys_ticrate
  • teamplay
  • teamplay global
  • telefrag
  • time
  • total_monsters
  • total_secrets
  • trace_allsolid
  • trace_endpos
  • trace_ent
  • trace_fraction
  • trace_inopen
  • trace_inwater
  • trace_plane_dist
  • trace_plane_normal
  • trace_startsolid
  • traceline
  • unit vector
  • v_cshift
  • v_forward
  • v_right
  • v_up
  • var
  • vector
  • vector type
  • velocity vector
  • vid_mode
  • vid_nopageflip
  • vid_stretch_by_2
  • vlen
  • void
  • void type
  • volume
  • vtos
  • wait
  • while
  • world
  • world vector
  • worldspawn
  • xage
  • |
  • ||
  • |||
View Source of this page Last edited on October 29, 2002 PageHistory Info


All Users

Quake Wiki: HomePage All Users

Authenticated users on this wiki (23 total):
Page Name | Version
Dr. Shadowborg ? | 0
FrikaC | 5
Gleeb | 2
ImUnreal | 1
Jimbo ? | 0
KrimZon ? | 0
Maddes | 1
Rick | 3
SeienAbunae | 2
Slot Zero ? | 0
Tei | 4
Tomaz ? | 0
c0burn ? | 0
cobalt | 1
diGGer | 2
frikqcc ? | 0
hexed | 1
jerryx1 ? | 0
mechtech ? | 0
painkiller ? | 0
reconn ? | 0
rocketman | 1
stef.feola | 1

-- Question: What does 'Version' mean? -- SeienAbunae
-- Answer: The number of times their homepage has been edited -- FrikaC

View Source of this page Last edited on December 4, 2002 PageHistory Info


Ammo Boxes

There are 4 types of ammo. Each type comes in boxes of 2 sizes:

  • Shells - 20 or 50 per box
  • Nails - 25 or 50 per box
  • Rockets - 5 or 10 per box
  • Cells - 6 or 12 per box

Rockets also double as grenades for the grenade launcher. The weapons themselves usually come with a small quantity of ammo.

The engines that support md3 models, Telejano, Qure and the latest Darkplaces, can use Md3 high-quality model subtitution.

  • Telejano ModelPak ?
    • http://telejano.berlios.de/option/modelpack1.zip
    • http://telejano.berlios.de/option/update67.zip
View Source of this page Last edited on April 29, 2003 PageHistory Info


Arrays

Quake Wiki: HomePage Arrays

"Easier to Use" Arrays

FrikQCC 2.5 implements global arrays that I personally find easier to use than JP Grossman's entity field hacks. First off to declare an array, you, unlike C, place the size of the array next to the type, like so:

float[5] newarray;

This defines 5 elements (note the elements are actually numbered 0, 1, 2, 3 and 4. This is like C and unlike BASIC, if you're used to that). In addition, you've automatically declared a special "array header" variable, but you don't need to worry about that now.

To access the elements of the array, you use the square brackets again:

newarray[1] = 56.6;
bprint(ftos(newarray[1]));

Would print 56.6. You can of course use a variable to index into the array:

int i;

i = 0;
while (i < 5)
{

newarray[i] = 33.3;
i = i + 1;

}

The above code would completely fill newarray with 33.3. There is another, more advanced and less useful way you can access the elements of an array. You see, at declaration time, FrikQCC will set up a unique name for each element of the array - much like vectors in QuakeC have always been handled, and you can use these names rather than indexing with [] if you need a quick way into the array. The format of the names is the name of the array, the underscore character and the number of the index.

newarray_0 = 33.3;
newarray_1 = 33.3;
newarray_2 = 33.3;
newarray_3 = 33.3;
newarray_4 = 33.3;

Would again fill newarray with the value 33.3. You can also do multi dimensional arrays with FrikQCC. A multidimensional array is essentially an array of arrays. Consider the following:

float[5][5] biggerarray;

This would declare 5 * 5 elements, or 25 elements aswell as 6 array header vars.

FrikQCC arrays have been tested and found not to work with QuakeDC.

View Source of this page Last edited on December 10, 2002 PageHistory Info


Available Cvars

Quake Wiki: HomePage Available Cvars

Completely unused:

  • saved1
  • saved2
  • saved3
  • saved4
  • savedgamecfg
  • scratch1 ?
  • scratch2 ?
  • scratch3 ?
  • scratch4 ?
  • gamecfg ?
  • nomonsters ?

Minimal QuakeC use:

  • temp1 ?
View Source of this page Last edited on November 18, 2002 PageHistory Info


Axe

Ammunition used: none
Ammunition usage: none
Shot type: hitscan
Damage per shot: 20
Damage per second (max): 40
Range: 64 units
Cycle time: 0.5s

The last resort. Face it -- going toe-to-toe with the ugles in Quake demonstrates all the good sense of a man parachuting into an alligator farm.

You start Quake with the Axe and the Shotgun. You will rarely use the Axe, probably never, but it's there. There is the occasion where you might want to use it on a lone Grunt, to conserve ammo. Or, when you have the Quad Damage, it makes an effective Zombie-beater. But other than that, ignore it.

See Also: Weapons

View Source of this page Last edited on December 1, 2002 PageHistory Info


Back Links

Quake Wiki: HomePage Back Links

The contents of all pages are searched to find links to the current page. The BackLinks function also answers the question: "Which pages contain the title of this page?".

3 pages link to PhpWikiAdministration:

  • PgsrcTranslation
  • ReleaseNotes
  • WikiPlugin
View Source of this page Last edited on October 29, 2002 PageHistory Info


Biosuit

The Biosuit is a powerup which can be picked up to protect your skin from flesh eating slime. It lasts for 30 seconds before wearing off.

See Also: Items

View Source of this page Last edited on November 30, 2002 PageHistory Info


Builtin Function List

Quake Wiki: HomePage Builtin Function List

QuakeC uses builtin functions to call bits of C code that can do 'jobs' for the QC that otherwise can't be done. Some functions affect the game world, some modify variables, and some maintain file lists for the engine. Each of the original functions are detailed below.

NormalQuake (NQ) Functions

  • aim ?
  • ambientsound ?
  • bprint
  • ceil ?
  • centerprint
  • changelevel ?
  • checkbottom ?
  • checkclient
  • ChangeYaw ?
  • cvar
  • cvar_set ?
  • dprint ?
  • droptofloor ?
  • eprint ?
  • error ?
  • fabs ?
  • find
  • findradius ?
  • floor
  • ftos
  • lightstyle ?
  • localcmd
  • makestatic
  • makevectors
  • movetogoal
  • nextent
  • normalize ?
  • objerror ?
  • particle
  • pointcontents ?
  • precache_file2 ?
  • precache_file
  • precache_model2 ?
  • precache_model
  • precache_sound2 ?
  • precache_sound ?
  • random
  • remove
  • rint ?
  • setmodel
  • setorigin
  • setsize ?
  • setspawnparms ?
  • sound ?
  • spawn
  • sprint
  • stuffcmd
  • traceline
  • vectoangles ?
  • vectoyaw ?
  • vlen
  • vtos
  • walkmove ?
  • WriteAngle
  • WriteByte
  • WriteChar
  • WriteCoord ?
  • WriteEntity ?
  • WriteLong
  • WriteShort ?
  • WriteString

QuakeWorld (QW) Functions

  • logfrag ?
  • infokey ?
  • stof ?
  • multicast ?

Other Engines

Telejano (NQ)

  • cvarstring
  • readline ?
View Source of this page Last edited on November 25, 2002 PageHistory Info


Burning Tutorials

Quake Wiki: HomePage Burning Tutorials

QuakeDC Burning Tutorials

See QuakeDev's site for burning a non self-booting CD:
http://quakedev.dcemulation.com/tutorials.htm

For instructions with self-booting CD's, please refer to:
http://homebrew.dcemulation.com/selfboot.htm

View Source of this page Last edited on November 25, 2002 PageHistory Info


Calendar Plugin

Quake Wiki: HomePage Calendar Plugin

The CalendarPlugin can be used to generate a monthly calendar in a wiki page. It's handy for PersonalWiki ?s.

Individual dates in the calendar link to specially named wiki pages. The names for the "day pages" are by default formed by appending the date to the pagename on which the calendar appears.

This feature was inspired by Manila, and first implemented by GaryBenson ?. It was later implemented as a WikiPlugin by JeffDairiki ?.

Usage:

 <?plugin Calendar?>

wil get you:

< May, 2003 >
Sun Mon Tue Wed Thu Fri Sat
1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31

Plugin Arguments

Selection of Month

year
current year.)
month
current month.)
month_offset
Added to month. Can be used to include several months worth of calendars on a single wiki page.
< June, 2003 >
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30

"Day Page" Names

date_format
strftime] style format string used to generate page names for the "day pages." The default value is 'zY-zm-zd'.
prefix
'.

Appearance

month_format
'zB, zY'.)
wday_format
strftime] style format string used to generate the day-of-week names at the top of the calendar.
start_wday
What day of the week does the calendar start on. This should be specified as an integer in the range zero (Sunday) through six (Saturday), inclusive.
< May, 2003 >
Mon Tue Wed Thu Fri Sat Sun
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31

Patch for 1.2

GaryBenson ? wrote the first calendar implementation for PhpWiki 1.2. (Since 1.2 doesn't support plugins, it uses a ###CALENDAR### token as a trigger.) Gary provides a screenshot at http://inauspicious.org/files/screenshots/calender.png, a patch (on 1.2.0), and calendar.php (which renders a view of the year.)

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Camper

Players that stay in one specific area in the map, waiting for others to come to them. It is a smart strategy, but it is frowned upon for the fact that it hinders eventfull gameplay. Most of the online Quake community now heavily frown on the act of camping, and refuse to play with them. Some mods have anti-camping protection to prevent excessive use of it.

View Source of this page Last edited on November 26, 2002 PageHistory Info


Category Category

Quake Wiki: HomePage Category Category

  • CategoryHomePages
View Source of this page Last edited on October 29, 2002 PageHistory Info


Category Home Pages

Quake Wiki: HomePage Category Home Pages

Authenticated users on this wiki (12 total):

  • FrikaC
  • Gleeb
  • ImUnreal
  • Maddes
  • Rick
  • SeienAbunae
  • Tei
  • cobalt
  • diGGer
  • hexed
  • rocketman
  • stef.feola

CategoryCategory

View Source of this page Last edited on October 29, 2002 PageHistory Info


Cheap Alert

Quake Wiki: HomePage Cheap Alert

I mod. Alot.

I'm obsessed with gargoyles. Very. (NOT the Disney crap)

I terrorize 18 forums at once.

I have lots of time.

I'm also very busy.

Wanna know what's cute?

THAT's cute.

Other Users Comments

Gleeb: Sometimes has a good idea, the rest of the time, he's a bit off...

View Source of this page Last edited on March 31, 2003 PageHistory Info


Cheap Hack

Quake Wiki: HomePage Cheap Hack

CheapHack: CheapAlert quake engine, cool water and blood. Interesting detail texture code. Derived from TomazQuake code.

View Source of this page Last edited on November 14, 2002 PageHistory Info


Chthon

Weapon: Explosive Lava Balls
Health: N/A
Treasure: Nothing

Tips: The mighty Chthon can't be harmed by conventional weapons. He hurls explosive lava balls that explode small and are easy to run away from in Easy difficulty, but if you're playing on Hard, you will have to use some fancy footwork to avoid his path-predicting aim. His lair has a trap set up that you will have to use to kill him. Go up the elevator, and press the two floorplate buttons on either side of Chthon to lower the lightning trap. You will need to lower both to hit him. Then, go back to the third button, in front of him, and step on it send a powerful lightning bolt surging between the two pillars. Hopefully with Chthon in the middle. It will only take one zap to kill him on Easy difficulty, otherwise you'll need to do it three times (each time you zap him the pillars go back up).

Entity name: monster_boss ?

See Also: Monsters

View Source of this page Last edited on March 16, 2003 PageHistory Info


Client Connect

Quake Wiki: HomePage Client Connect

void() ClientConnect;

Called by the engine when a client connects to the game. Not really used extensively in the QC, only for one time events such as bprinting that the client has connected and (sometimes) initializing a few variables. PutClientInServer is typically used for setting the client's entity up for gameplay.

View Source of this page Last edited on December 9, 2002 PageHistory Info


Client Kill

Quake Wiki: HomePage Client Kill

void() ClientKill;

This function is called by the engine when the server recieves the kill ? command from a client. Upon calling self is set to the client that originated the command. Typically, you'd give the player a penalty for using the command (such as subtracting from his .frags ?) but it can really be used for just about anything.

It's a good idea to put a timer on the frequency of use of this function, so there won't be 'suicide spammers' when you play online.

View Source of this page Last edited on November 20, 2002 PageHistory Info


Command Line Parameters

Quake Wiki: HomePage Command Line Parameters

  • +
  • -allow360
  • -basedir
  • -cachedir
  • -condebug ?
  • -conheight
  • -conwidth
  • -current
  • -dedicated
  • -dibonly ?
  • -dinput ?
  • -force ?
  • -fullsbar ?
  • -game
  • -heapsize ?
  • -height
  • -hipnotic
  • -ip
  • -ipxport ?
  • -listen
  • -minmemory ?
  • -mode ?
  • -noadjustaspect ?
  • -noautostretch ?
  • -nocdaudio
  • -nodd ?
  • -noddraw ?
  • -nodirectdraw ?
  • -noforcemaccel ?
  • -noforcemparms ?
  • -noforcemspd ?
  • -noforcevga ?
  • -nofulldib ?
  • -noipx ?
  • -nojoy ?
  • -nolan ?
  • -nomouse ?
  • -nosound ?
  • -notriplebuf ?
  • -noudp ?
  • -novbeaf ?
  • -novesa ?
  • -nowd ?
  • -nowindirect ?
  • -particles
  • -path ?
  • -playback ?
  • -port ?
  • -primarysound ?
  • -proghack ?
  • -record ?
  • -resetwinpos ?
  • -rogue
  • -safe ?
  • -simsound ?
  • -snoforceformat ?
  • -starttime ?
  • -startwindowed ?
  • -stdvid ?
  • -surfcachesize ?
  • -udpport ?
  • -wavonly ?
  • -width
  • -window
  • -zone ?
View Source of this page Last edited on November 19, 2002 PageHistory Info


Console Commands

Quake Wiki: HomePage Console Commands

  • +attack ?
  • +back ?
  • +forward ?
  • +jump ?
  • +klook ?
  • +left ?
  • +lookdown ?
  • +lookup ?
  • +mlook
  • +movedown ?
  • +moveleft ?
  • +moveright ?
  • +moveup ?
  • +right ?
  • +showscores ?
  • +speed ?
  • +strafe ?
  • +use ?
  • -attack ?
  • -back ?
  • -forward ?
  • -jump ?
  • -klook ?
  • -left ?
  • -lookdown ?
  • -lookdown ?
  • -lookup ?
  • -mlook
  • -movedown ?
  • -moveleft ?
  • -moveright ?
  • -moveup ?
  • -right ?
  • -showscores ?
  • -speed ?
  • -strafe ?
  • -use ?
  • alias ?
  • ban ?
  • begin ?
  • bf
  • bind ?
  • cd ?
  • centerview
  • changelevel
  • clear
  • cmd ?
  • color
  • connect ?
  • demos ?
  • disconnect ?
  • echo
  • edict ?
  • edictcount ?
  • edicts ?
  • entities ?
  • envmap ?
  • exec ?
  • flush ?
  • fly
  • force_centerview
  • give ?
  • god
  • help ?
  • impulse
  • joyadvancedupdate ?
  • kick ?
  • kill ?
  • listen ?
  • load ?
  • map
  • mcache ?
  • menu_keys ?
  • menu_load ?
  • menu_main ?
  • menu_multiplayer ?
  • menu_options ?
  • menu_quit ?
  • menu_save ?
  • menu_setup ?
  • menu_singleplayer ?
  • menu_video ?
  • messagemode ?
  • messagemode2 ?
  • name
  • net_stats ?
  • noclip
  • notarget ?
  • path ?
  • pause ?
  • ping ?
  • play ?
  • playdemo ?
  • playvol ?
  • pointfile
  • prespawn ?
  • profile ?
  • quit
  • reconnect ?
  • record ?
  • restart
  • save ?
  • say ?
  • say_team ?
  • screenshot
  • sizedown ?
  • sizeup ?
  • slist ?
  • soundinfo ?
  • soundlist ?
  • spawn ?
  • startdemos ?
  • status
  • stop ?
  • stopdemo ?
  • stopsound ?
  • stuffcmds ?
  • tell ?
  • test ?
  • test2 ?
  • timedemo ?
  • timerefresh ?
  • toggleconsole ?
  • togglemenu ?
  • unbind ?
  • unbindall ?
  • v_cshift
  • version ?
  • vid_describecurrentmode ?
  • vid_describemode ?
  • vid_describemodes ?
  • vid_forcemode ?
  • vid_fullscreen ?
  • vid_minimize ?
  • vid_nummodes ?
  • vid_testmode ?
  • vid_windowed ?
  • viewframe ?
  • viewmodel ?
  • viewnext ?
  • viewprev ?
  • wait
View Source of this page Last edited on November 4, 2002 PageHistory Info


Console Variables

Quake Wiki: HomePage Console Variables

  • _cl_color
  • _cl_name
  • _config_com_baud
  • _config_com_irq
  • _config_com_modem
  • _config_com_port
  • _config_modem_clear
  • _config_modem_dialtype
  • _config_modem_hangup
  • _config_modem_init
  • _snd_mixahead
  • _vid_default_mode ?
  • _vid_default_mode_win ?
  • _vid_wait_override ?
  • _windowed_mouse
  • ambient_fade ?
  • ambient_level
  • bgmbuffer ?
  • bgmvolume
  • block_switch ?
  • chase_active ?
  • chase_back ?
  • chase_right ?
  • chase_up ?
  • cl_anglespeedkey ?
  • cl_backspeed ?
  • cl_bob
  • cl_bobcycle ?
  • cl_bobup ?
  • cl_forwardspeed ?
  • cl_movespeedkey ?
  • cl_nolerp ?
  • cl_pitchspeed ?
  • cl_rollangle ?
  • cl_rollspeed ?
  • cl_shownet ?
  • cl_sidespeed ?
  • cl_upspeed ?
  • cl_yawspeed ?
  • cmdline ?
  • con_notifytime ?
  • coop
  • crosshair
  • d_mipcap ?
  • d_mipscale ?
  • deathmatch
  • developer ?
  • echo
  • edgefriction ?
  • fov
  • fraglimit ?
  • gamecfg ?
  • gamma ?
  • gl_affinemodels ?
  • gl_clear
  • gl_cull ?
  • gl_finish ?
  • gl_flashblend
  • gl_keeptjunctions
  • gl_max_size ?
  • gl_nobind ?
  • gl_nocolors ?
  • gl_picmip ?
  • gl_playermip ?
  • gl_polyblend
  • gl_reporttjunctions ?
  • gl_smoothmodels ?
  • gl_subdivide_size ?
  • gl_texsort
  • gl_texturemode ?
  • gl_triplebuffer ?
  • gl_ztrick
  • host_framerate ?
  • host_speeds ?
  • hostname ?
  • joyadvanced ?
  • joyadvaxisr ?
  • joyadvaxisu ?
  • joyadvaxisv ?
  • joyadvaxisx ?
  • joyadvaxisy ?
  • joyadvaxisz ?
  • joyforwardsensitivity ?
  • joyforwardthreshold ?
  • joyname ?
  • joypitchsensitivity ?
  • joypitchthreshold ?
  • joysidesensitivity ?
  • joysidethreshold ?
  • joystick ?
  • joywwhack1 ?
  • joywwhack2 ?
  • joyyawsensitivity ?
  • joyyawthreshold ?
  • lcd_x ?
  • lcd_yaw ?
  • loadas8bit ?
  • lookspring ?
  • lookstrafe ?
  • m_filter ?
  • m_forward ?
  • m_pitch ?
  • m_side ?
  • m_yaw ?
  • maxplayers ?
  • net_messagetimeout ?
  • noexit ?
  • nomonsters ?
  • nosound ?
  • pausable ?
  • port ?
  • precache ?
  • r_aliastransadj
  • r_aliastransbase
  • r_ambient ?
  • r_clearcolor ?
  • r_drawentities ?
  • r_drawflat ?
  • r_draworder ?
  • r_drawviewmodel ?
  • r_dspeeds ?
  • r_dynamic ?
  • r_fullbright
  • r_graphheight ?
  • r_maxedges ?
  • r_lightmap ?
  • r_maxsurfs ?
  • r_mirroralpha ?
  • r_norefresh ?
  • r_novis ?
  • r_numedges ?
  • r_numsurfs ?
  • r_polymodelstats ?
  • r_reportedgeout ?
  • r_reportsurfout ?
  • r_shadows ?
  • r_speeds ?
  • r_timegraph ?
  • r_wateralpha ?
  • r_waterwarp ?
  • registered ?
  • samelevel ?
  • saved1
  • saved2
  • saved3
  • saved4
  • savedgamecfg
  • scr_centertime
  • scr_conspeed ?
  • scr_ofsx ?
  • scr_ofsy ?
  • scr_ofsz ?
  • scr_printspeed ?
  • scratch1 ?
  • scratch2 ?
  • scratch3 ?
  • scratch4 ?
  • sensitivity ?
  • serverprofile ?
  • showpause ?
  • showram ?
  • showturtle
  • skill
  • snd_noextraupdate ?
  • snd_show ?
  • sv_accelerate ?
  • sv_aim
  • sv_friction ?
  • sv_gravity
  • sv_idealpitchscale ?
  • sv_maxspeed ?
  • sv_maxvelocity ?
  • sv_nostep ?
  • sv_stopspeed ?
  • sys_ticrate
  • teamplay
  • temp1 ?
  • timelimit ?
  • v_centermove ?
  • v_centerspeed ?
  • v_idlescale ?
  • v_ipitch_cycle ?
  • v_ipitch_level ?
  • v_iroll_cycle ?
  • v_iroll_level ?
  • v_iyaw_cycle ?
  • v_iyaw_level ?
  • v_kickpitch ?
  • v_kickroll ?
  • v_kicktime ?
  • vid_config_x ?
  • vid_config_y ?
  • vid_fullscreen_mode ?
  • vid_mode
  • vid_nopageflip
  • vid_stretch_by_2
  • vid_wait ?
  • vid_window_x ?
  • vid_window_y ?
  • vid_windowed_mode ?
  • viewsize ?
  • volume
View Source of this page Last edited on November 25, 2002 PageHistory Info


Darkplaces

Quake Wiki: HomePage Darkplaces

go DarkPlaces

View Source of this page Last edited on November 14, 2002 PageHistory Info


Da Z

Quake Wiki: HomePage Da Z

Mapper!

http://www.planetquake.com/dazdranz/

makes maps that use new features of engines too (TomazQuake & Tenebrae)

eDJ!

http://www.dazv3.co.uk/

Mixes ACID, HARDSTYLE & HARD TRANCE

View Source of this page Last edited on April 3, 2003 PageHistory Info


DCQuake

Quake Wiki: HomePage DCQuake

DCQuake (Bero)

A port of Quake to the Dreamcast created by Bero.

  • DCQuake Downloads
  • DCQuake Modding Information
  • DCQuake Mod List
View Source of this page Last edited on November 26, 2002 PageHistory Info


DCQuake Downloads

DCQuake (Bero):
http://prdownloads.sourceforge.net/dcquake/dcquake-2002-08-11-bin.zip

View Source of this page Last edited on November 26, 2002 PageHistory Info


DCQuake Modding Information

Modding for DCQuake is the same process as modding for normal Quake, with a few exceptions:

  • The Dreamcast only has 16MB of RAM and no HD for a swap file
  • (software) DCQuake has problems that seem related to dynamic world lighting
  • Supports Dreamcast Keyboard (not everyone has one)
  • Is less sensitive to high polycounts (unlike QuakeDC)

So while making a mod that is DCQuake compatible, please consider keeping it light, somewhat low poly, and controller friendly.

DCQuake (Bero) Definitions:

  Dreamcast Pad      Bind         Default Setting
  dpad up            uparrow      +forward
  dpad down          downarrow    +back
  dpad left          leftarrow    +left
  dpad right         rightarrow   +right
  A button           enter        +jump
  B button           space        +jump
  X button           x            none
  Y button           y            none
  right trigger      CTRL         +attack
  left trigger       ALT          +sidestep

  Analog Stick works as an emulated mouse (moves by default or add +mlook to look)
  Binds are NOT set by the engine. Must be set in your config (if not already set)
  Both the software and GL ports use the same control setup.
  The GL port supports the pc glquake folder to reduce load times (no meshing on level change)
  Both software and GL support several mods per disc through a simple menu.
  (Its recommended you create a games.lst to use the mod menu.)
View Source of this page Last edited on November 26, 2002 PageHistory Info


DCQuake Mod List

This is a small list of the mods that currently work and have been tested with DCQuake.
(note: most of these, if not all, should work with the software version, the GL version may or may not work)

List:

  • Prydon Gate: http://www.inside3d.com/prydongate/
  • Codename: Corporal: http://quakedev.dcemulation.com/mods/codename/
  • FBXDC: http://www.inside3d.com/frikbot/dreamcast/fbxdc.zip
  • FrikMenu: files:frikmenu.zip
  • JoyMenu: http://quakedev.dcemulation.com/mods/joymenu/joymenu.htm
  • Raptors: http://quakedev.dcemulation.com/mods/raptors/raptors.htm
  • Raptors Return: http://quakedev.dcemulation.com/mods/raptors/return.htm
  • SaveQuake: http://www.inside3d.com/renegade/SaveQuake.zip
  • JoyConsole: http://www.thefragger.hpg.ig.com.br/mod_joyconsole_description.htm
View Source of this page Last edited on March 16, 2003 PageHistory Info


Death Knight

This particular canned meat tends to open you up instead.

Weapon: Sword, Fireballs
Health: 250
Treasure: Nothing

Tips: Death Knights do more damage with their swords than regular Knights, and also have a ranged weapon: Fireballs. They can throw multiple slow-moving fireballs, so get ready to dodge. For killing them, use the Double-Barrelled Shotgun at close range, otherwise you're going to want to use a Nailgun, or preferably, a Perforator. Rockets and Grenades work well too.

Entity name: monster_hell_knight ?

See Also: Monsters

View Source of this page Last edited on March 16, 2003 PageHistory Info


Debug Info

Quake Wiki: HomePage Debug Info

Detailed view of a page, which is probably more useful for debugging than anything else.

Querying backend directly for 'PhpWikiAdministration'

get_pagedata('PhpWikiAdministration')
hits | 64
locked | yes
get_versiondata('PhpWikiAdministration',1)
zcontent | __Note__: Most of the actions on this pa ...
author | The PhpWiki programming team
author_id | The PhpWiki programming team
is_minor_edit |
markup | 2
mtime | 1035923806
View Source of this page Last edited on October 29, 2002 PageHistory Info


Demo Tools

Quake Wiki: HomePage Demo Tools

  • Demtool - simple but useful tool for editing and compressing demos
  • ReMaic - Acronym for "Reshoot Existing Movie, Altering Its Camera", great tool for recamming
  • DeMix - A 'demo remixer'
  • Dzip - Demo compression utility
  • Film at 11 - A rather old tool
  • KeyGrip - Another oldie..
  • Demoplayer - ?
  • Little Movie Processing Centre

FIXME: make local download copies of all

See also:

  • Quake tools
  • Quake Done Quick
View Source of this page Last edited on December 1, 2002 PageHistory Info


Dont do list

Quake Wiki: HomePage Dont do list

Never do this:

  • remove a client entity. Read self
  • self .nextthink = self .nextthink + 0.1; will almost always be in the past. Read .nextthink
  • self .origin = somevector;. Read setorigin
  • self .model = somestring;. Read setmodel
View Source of this page Last edited on November 10, 2002 PageHistory Info


Double-Barrelled Shotgun

Ammunition used: Shells ?
Ammunition usage: 2/shot
Shot type: hitscan
Damage per shot: 56, divided among 14 pellets
Damage per second (max): 80
Range: 2048 units
Cycle time: 0.7s

A worthy weapon with three minor drawbacks: first, it uses up 2 shells per blast; second, it's slow; third, its shot pattern is very loose at long range. But in general, once you find this puppy, the other shotgun starts rusting from disuse.

The Double-Barrelled Shotgun uses 2 shells up per shot, but is a lot more effective at close range than the Shotgun. It is probably the most-used weapon in the game, and you'll first find it in a secret in e1m1, or else in e1m2 ?.

See Also: Weapons

View Source of this page Last edited on December 1, 2002 PageHistory Info


Downloads

Quake Wiki: HomePage Downloads

FrikQCC Downloads

  • FrikQCC 2.6 for Windows and DOS
  • FrikQCC 2.6 for Linux
  • FrikQCC 2.6 Source Code

QuakeC Downloads

  • QuakeC 1.06

Misc & Unsupported Downloads

  • meQCC 1.4 Source
View Source of this page Last edited on March 16, 2003 PageHistory Info


Dreamcast Quake

A port of Quake to the Dreamcast console system, currently, there are two ports of this the Titanium version, and the Bero version. As a note, both author's named these versions differently, Titanium's port is known as QuakeDC, while Bero's port is known as DCQuake.

Both ports aren't perfect, but are close. They also support mods. See the burning tutorials for burning it and/or mods.

Information:

  • QuakeDC
  • DCQuake
  • Burning Tutorials
  • Port Differences
View Source of this page Last edited on November 26, 2002 PageHistory Info


Dr Labman

Quake Wiki: HomePage Dr Labman

DrLabman is a quake engine programmer. Mastermind behind the QMB engine.

View Source of this page Last edited on November 26, 2002 PageHistory Info


EBSP

Quake Wiki: HomePage EBSP

EBSP, created by FrikaC, is a way of storing content within the BSP ?

For example, it could contain high resolution textures, high quality sounds or even a coooool skin for the player that matches the level.

SeienAbunae asked for elaboration...

EBSP is a new BSP format, backwards compatible with other engines. It is best explained as a combined pak and bsp. It needs engine support, but it's easy to implement. Details will be forthcoming soon.

<Tei> Maybe you can download a incomplete implementation from http://www.fileplanet.com/dl/dl.asp?/planetquake/gzone/ebsp1.zip or maybe you can download the Gleeb GQ engine (it support EBSP) for reference. </Tei>

View Source of this page Last edited on April 30, 2003 PageHistory Info


Edit Text

Quake Wiki: HomePage Edit Text

All pages (except search results) have an EditText link at the bottom. You can edit the page you are reading by clicking that link.

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Eliminate Duplicate Defs

Quake Wiki: HomePage Eliminate Duplicate Defs

/Od - Eliminate duplicate defs

If two constant variables have the same value, only one def is used. Another space optimization. This is merely an extension of something QCC already did, it reused constant defs for immediates. The extension allows other constants to re-use constants, and as such doesn't change the decompilability of the progs.

View Source of this page Last edited on November 4, 2002 PageHistory Info


Eliminate Constant Names and Defs

Quake Wiki: HomePage Eliminate Constant Names and Defs

/Oc - Eliminate constant defs/names

The names and associated defs of constant variables are not stored in the progs.dat. This is a space optimization and does not affect speed. This can make the progs.dat harder to decompile. Unless the decompiler can make up names for the the constants, the decompiler will choke.

View Source of this page Last edited on November 4, 2002 PageHistory Info


Eliminate Local Names

Quake Wiki: HomePage Eliminate Local Names

/Ol - Eliminate local names

The names of local, static and immediates are stripped from the progs.dat upon write time. This saves some space, and does not affect the usability of the compiled code. This also makes it harder to be decompiled.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Eliminate Source Code Filenames

Quake Wiki: HomePage Eliminate Source Code Filenames

/Of - Eliminate source code filenames

Another space optimization, file names of the source files are not stored in the compiled progs. This will affect decompilation on older decompilers.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Eliminate Temporary Variables

Quake Wiki: HomePage Eliminate Temporary Variables

/Ot - Eliminate Temporary Variables

This is one of JP Grossman's optimizations it flattens store opcodes into one line. This optimization can cause decompilers to choke, if they don't recognize the improved generated code.

OP A, B, temp
STORE temp, C

to

OP A, B, C

View Source of this page Last edited on October 30, 2002 PageHistory Info


Eliminate Uneeded Function Names

Quake Wiki: HomePage Eliminate Uneeded Function Names

/On - Eliminate uneeded function names

The function names of any function assigned to a built-in are removed from the progs.dat. Again, a space optimization only. This doesn't affect decompilation.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Enforcer

Grunt, Mark Two. Grunts who are surlier and beefier than the rest get outfitted in combat armour and built-in blasters.

Weapon: Blaster
Health: 80
Treasure: 5 cells

Tips: They pack blasters and have perfect aim, but the blaster projectiles are slow-moving, so you must be fast-moving. Take them out with two good Double-Barrelled Shotgun hits or attack with the Nailgun, Perforator, Grenade Launcher or Rocket Launcher.

Entity name: monster_enforcer ?

See Also: Monsters

View Source of this page Last edited on November 25, 2002 PageHistory Info


Engines

Quake Wiki: HomePage Engines

Screenshots

  • The best of 2002 Screenshots, by Tei
  • The best of 2003 Screenshots, by Tei

SinglePlayer Quake Engines - Singleplayer. No net support.

Industry: http://industri.sourceforge.net/
Scoped: http://scoped.sourceforge.net
SinglePlayer: Telejano:SinglePlayer

NetQuake - Singleplayer, Multiplayer. Lan, Internet.

Darkplaces: http://www.icculus.org/twilight/darkplaces/
TomazQuake: http://tomaz.quakesrc.org/
MHQuake: http://mhquake.quakesrc.org/
QMB: http://qmb.quakepit.com/
GQ: http://www.planetquake.com/gzone/gq.shtml
Telejano: http://telejano.berlios.de/wiki3/
Tenebrae: http://tenebrae.sourceforge.net/
Pro-Quake: http://www.planetquake.com/proquake/
NPRQuake: http://www.cs.wisc.edu/graphics/Gallery/NPRQuake/
CheapHack: http://chphack.moddb.com
FitzQuake: http://www.celephais.net/fitzquake/
NetChild: http://home.online.no/~quaker/netchild/main.htm
TTyQuake: http://webpages.mr.net/bobz/ttyquake/
Icon Quake: http://freshmeat.net/projects/wmquake/
NewWolf ? (mix engine, q1&q2): http://newwolf.sourceforge.net/

QuakeWorld (QW) Engines - Multiplayer. Lan/Internet area.

FuhQuake: http://www.fuhquake.net/
ZQuake: http://zquake.frag.ru/eng/news/index.shtml
MoreQuakeWorld: http://hem.passagen.se/mjyyk/mqwcl/news.html
Twilight: http://twilight.sourceforge.net/
QuakeForge: http://www.quakeforge.net/
KrimZoN QuakeWorld Client: http://slightly.quakesrc.org/
QuakeWorld Python: http://freshmeat.net/projects/qwpython/
Spike Engine: http://spike.corecodec.org/

QuakeWorld (QW) Servers

The GeneBot Project http://www.telefragged.com/thefatal/genebot.shtml

Dreamcast Quake Engines

Titanium Port (QuakeDC): http://dumbass.hypermart.net/presents/downloads/quakedc/quakedc_req.htm
Bero Port (DCQuake): http://prdownloads.sourceforge.net/dcquake/dcquake-2002-08-11-bin.zip

View Source of this page Last edited on May 4, 2003 PageHistory Info


Engine Tutorials

Quake Wiki: HomePage Engine Tutorials

Tutorials

  • Improving Teamplay ?
  • Changing Graphics ?
  • Solved Bugs ?
  • New Console features ?
  • QuakeC implementations ?
  • Demos Editing ?
  • Others Tutorials ?

See Also

  • QuakeSrc.org tutorials
View Source of this page Last edited on November 25, 2002 PageHistory Info


Enhanced Engine Features

Quake Wiki: HomePage Enhanced Engine Features

  • RScripts ?
  • LocalMenus
  • ModelScripts ?
  • HudModels
  • Console HUD Control ?
  • ENV Heighfields, ENVs ?
  • SHOWLmp ?
  • Client Side Mods ?
View Source of this page Last edited on May 2, 2003 PageHistory Info


Entity Guide

  • worldspawn
  • info_player_start
  • info_player_deathmatch ?
  • info_player_coop ?
  • info_player_start2 ?
  • info_teleport destination ?
  • info_null ?
  • info_intermission ?
  • item_cells ?
  • item_rockets ?
  • item_shells ?
  • item_spikes ?
  • item_health ?
  • item_artifact_envirosuit ?
  • item_artifact_super_damage ?
  • item_artifact_invulnerability ?
  • item_artifact_invisibility ?
  • item_armorInv ?
  • item_armor2 ?
  • item_armor1 ?
  • item_key1 ?
  • item_key2 ?
  • item_sigil ?
  • weapon_supershotgun ?
  • weapon_nailgun ?
  • weapon_supernailgun ?
  • weapon_grenadelauncher ?
  • weapon_rocketlauncher ?
  • weapon_lightning ?
  • monster_army ?
  • monster_dog ?
  • monster_ogre ?
  • monster_ogre_marksman
  • monster_knight ?
  • monster_hell_knight ?
  • monster_wizard
  • monster_demon1 ?
  • monster_shambler ?
  • monster_boss ?
  • monster_enforcer ?
  • monster_shalrath ?
  • monster_tarbaby ?
  • monster_fish ?
  • monster_oldone ?
  • monster_zombie ?
  • light ?
  • light_fluoro ?
  • light_fluorospark ?
  • light_globe ?
  • light_flame_large_yellow ?
  • light_flame_small_yellow ?
  • light_flame_small_white ?
  • light_torch_small_walltorch ?
  • air_bubbles ?
  • event_lightning ?
  • misc_fireball ?
  • misc_explobox ?
  • misc_explobox2 ?
  • trap_spikeshooter ?
  • trap_shooter ?
  • ambient_drip ?
  • ambient_drone ?
  • ambient_comp_hum ?
  • ambient_flouro_buzz ?
  • ambient_light_buzz ?
  • ambient_suck_wind ?
  • ambient_swamp1 ?
  • ambient_swamp2 ?
  • ambient_thunder ?
  • func_door ?
  • func_door_secret ?
  • func_wall ?
  • func_button ?
  • func_train ?
  • path_corner ?
  • func_plat ?
  • func_dm_only ?
  • func_illusionary ?
  • func_episodegate ?
  • func_bossgate ?
  • trigger_changelevel ?
  • trigger_once ?
  • trigger_multiple ?
  • trigger_onlyregistered ?
  • trigger_secret ?
  • trigger_teleport ?
  • trigger_setskill ?
  • trigger_relay ?
  • trigger_monsterjump ?
  • trigger_counter ?
  • trigger_push ?
  • trigger_hurt ?
View Source of this page Last edited on November 24, 2002 PageHistory Info


ENV Heighfields

Its the ability to render 512x512 heighfield maps with custom scale. QURE and Telejano implement this heighfields to support big outdoor maps.

Related cvars:

  • heighfield location
    • env_x
    • env_y
    • env_z
  • heighfield scale
    • env_sx
    • env_sy
    • env_sz
    • env_stex
    • env_sdetail
  • heighfield perfomance
    • env_detail
    • env_detaildist

Some screenshots:

  • Telejano

  • QURE

  • Some Editor

View Source of this page Last edited on May 2, 2003 PageHistory Info


Errorabove

Quake Wiki: HomePage Errorabove

Errorabove is the self-proclaimed guardian of the letter 'g'. Do not touch this letter, for it contains mystical powers. And as the guardian of the letter 'g', Errorabove has no rights to do anything.

View Source of this page Last edited on November 28, 2002 PageHistory Info


External Search

Quake Wiki: HomePage External Search

Perform a full-text search on MeatBall ? wiki:

Search the PHP web site for a function name:

Enter the name of a PHP function to view the documentation page:
replace all underscores _ with hyphens - in the function name

Enter any existing page name on PhpWiki to jump to that page:

View Source of this page Last edited on October 29, 2002 PageHistory Info


FALSE

Quake Wiki: HomePage FALSE

float FALSE = 0;

False, in computer terms means 0. The FALSE definition in QuakeC is a shortcut to specifying zero. Compare to TRUE.

For other types there are other FALSE equivalents: world for entities, null for strings, etc.

View Source of this page Last edited on December 10, 2002 PageHistory Info


FARC

Farc is an archive tool I'm currently working on. I started it to aid people in using EBSP, however it's turning into much, much, more. Farc is not at all related to FAR Manager, I didn't even know FAR existed when I started Farc, even though the similarty in name and function is similar, it's purely coincidental. Here's an old screenshot:

Farc is coded in pure C using Windows API and shell functions and doesn't use evile MFC or VB. This means that Farc requires no support DLLs or registry settings to install. Formats supported as of January 26th, 2003

Game Name | Format | Plugin | Notes
4x4 Evolution | POD2 | pod.dll |
4x4 Evolution 2 | POD2 | pod.dll |
Alien Vs. Predator 2 | REZ | rez.dll | Untested
American McGee ?'s Alice | PK3 | zip.dll |
Black & White | SAD | lionhead.dll | Works with most B&W packages but SAD is the only one with useful data (sounds)
Black & White Creature Isle | SAD | lionhead.dll | Works with most B&W packages but SAD is the only one with useful data (sounds)
Blair Witch | POD2 | pod.dll |
Blair Witch II | POD2 | pod.dll |
Blood 2 | REZ | rez.dll | Untested
Diablo | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Diablo Hellfire | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Diablo II | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Diablo II: Lord of Destruction | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Die Hard: Nakotomi Plaza | REZ | rez.dll | Untested
Doom | WAD1 | wad.dll | Needs work
Doom 2 | WAD1 | wad.dll | Needs work
Duke Nukem 3D | GRP | grp.dll |
Empire Earth | SSA | ssa.dll | DCL decompression from MQView
General Archive Formats | ZIP | zip.dll | Really just a wrapper for zlib http://www.zlib.org
General Archive Formats | RAR | rar.dll | Really just a wrapper for UniquE RAR Library http://www.unrarlib.org/, no save support
Grand Theft Auto 3 | DIR, IMG | gta3img.dll |
Grand Prix 4 | WAD | wad.dll | Not a normal wad, more like a GRP
Gunman Chronicles | PAK, WAD3 | pak.dll, wad.dll |
Half Life | PAK, WAD3 | pak.dll, wad.dll |
Heavy Metal: FAKK2 | PK3 | zip.dll |
Heretic | WAD1 | wad.dll | Needs work
Heretic II | PAK | pak.dll |
Hexen | WAD1 | wad.dll | Needs work
Hexen II | PAK, WAD2 | pak.dll, wad.dll |
Hitman | ZIP | zip.dll |
Hitman 2 | ZIP | zip.dll |
Jedi Knight 2 | PK3 | zip.dll |
Kingpin | PAK | pak.dll |
KISS: Psycho Circus | REZ | rez.dll |
Lord of Magic | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Medal of Honor: Allied Assualt | PK3 | zip.dll |
Microsoft Fury3 | POD1 | pod.dll |
Microsoft Hellbender | POD1 | pod.dll |
Monster Truck Madness | POD1 | pod.dll |
Monster Truck Madness 2 | POD1 | pod.dll |
No One Lives Forever | REZ | rez.dll |
No One Lives Forever 2 | REZ | rez.dll |
Nocturne | POD1, POD2 | pod.dll |
Quake | PAK, WAD2 | pak.dll, wad.dll |
Quake 2 | PAK | pak.dll |
Quake 3 | PK3 | zip.dll |
Redneck Rampage | GRP, WAD1 | grp.dll, wad.dll | .rts is a wad1
Return to Castle Wolfenstein | PK3 | zip.dll |
Rise of the Triad | WAD1 | wad.dll | .rts is a wad1
Serious Sam | GRO | zip.dll |
Serious Sam: Second Encounter | GRO | zip.dll |
Shadow Warrior | GRP, WAD1 | grp.dll, wad.dll | .rts is a wad1
Shogo | REZ | rez.dll | Untested
Sims | FAR | far.dll |
Sims Deluxe | FAR | far.dll |
Sims Livin' Large | FAR | far.dll |
Sims House Party | FAR | far.dll |
Sims Hot Date | FAR | far.dll |
Sims Vacation | FAR | far.dll |
Sims Unleashed | FAR | far.dll |
Sin | SIN | pak.dll |
Sniper: Path of Vengeance | REZ | rez.dll |
Soldier of Fortune | PAK | pak.dll |
Soldier of Fortune 2 | PK3 | zip.dll |
Star Trek: Elite Force | PK3 | zip.dll |
Star Wars: Rogue Squadron | BUNDLE | rogue.dll |
Starcraft | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Starcraft: Broodwar | MPQ | mpq.dll | Uses Stormlib by Ladislav Zezula
Strife | WAD1 | wad.dll | Untested, Needs work
SWAT 3 | RES | zip.dll |
Terminal Velocity | POD1 | pod.dll |
Thief: The Dark Project | CRF | zip.dll |
Thief 2 | CRF | zip.dll |
Vampire: The Masquerade: Redemption | NOB | zip.dll |
Warcraft 2: Battle Net Edition | MPQ | mpq.dll |
Witchaven | GRP | grp.dll |
Witchaven 2 | GRP | grp.dll |

All formats are supported via plugin dlls. To add support, merely place a new dll in the plugins folder (any dll can be deleted if not desired). All parts of this program will be fully open source (both the main editor and all plugins) once the program is released (but most likely not GPL, due to a lot of "borrowing"). There is no planned support for images or sound conversion, all files are displayed in their rawest form.

Here's some very preliminary and very messy code. If you improve upon this crap, edit this page and add your improvements, please.

  • files:farc_src.zip - Source code
  • files:farc_bin.zip - Binaries

Some other similar but better tools:

  • Game File Explorer
  • eXtendable Wad Editor
  • PakScape
  • MultiEx Commander
View Source of this page Last edited on April 12, 2003 PageHistory Info


Fiend

In essence, organic buzzsaws, rife with pummeling power!

Weapon: Arms, Leap
Health: 300
Treasure: Nothing

Tips: Fiends are definitely a tough cookie to crack. Get ready to strafe alot, because they leap fast and do major damage if they hit you. When they're close, they'll use their razor-sharp handless arms to rip the flesh from your bones. About four good hits from the Double-Barrelled Shotgun is a good way to take them out, or, if your far enough away, three Rockets.

Entity name: monster_demon1 ?

See Also: Monsters

View Source of this page Last edited on November 25, 2002 PageHistory Info


File Upload

Quake Wiki: HomePage File Upload

Here you can upload whole mods, text files or images to go along with your wiki entries. File size is limited to 4MB, and only .jpeg, .gif, .png, .zip and .txt files are allowed for security reasons. You must be registered and signed in to upload files. You can register at RegisterUser.

Title:
Upload this file:

Later on the title field will be used to list files each user has uploaded or for some sort of download front end (ala paFileDB).

View Source of this page Last edited on November 12, 2002 PageHistory Info


File Upload Submit

Quake Wiki: HomePage File Upload Submit

Incomplete form data. Please go back and try again.

View Source of this page Last edited on November 12, 2002 PageHistory Info


Find Page

Quake Wiki: HomePage Find Page

Here are some good starting points for browsing.

  • HowToUseWiki gives you the quick lowdown on Wiki markup.
  • RecentChanges recorded automatically.
  • MoreAboutMechanics of browsing and editing on this server.

Here's a title search. Try something like wiki or sandwich.

Use the following for a full text search. This takes a few seconds. The results will show all lines on a given page which contain a match.

In a fuzzy pages search the titles of all pages are examined to find those which are similarly spelled or similar sounding (english).

Tips

Separate words with a space. All words have to match.
To exclude words from a title search or full text search, prepend a '-'.
Example: 'wiki text -php' looks for all pages containing the words 'wiki' and 'text', but not containing the word 'php'.

View Source of this page Last edited on October 29, 2002 PageHistory Info


FL_MONSTER

Quake Wiki: HomePage FL_MONSTER

FL_MONSTER is an entity flag used to indicate that this entity is infact a monster (as if you couldn't tell by the blood stains and stench), this makes the entity subject to certain special behaviors such as being especially susceptible to nearby projectiles using MOVETYPE_FLYMISSILE, as if it is a whole 15 units wider than normal (in each direction).

FL_MONSTER is used by many parts of the id1 QuakeC, for example combat.qc's Killed function increases the monster kill counter when an entity baring the FL_MONSTER flag dies.

View Source of this page Last edited on April 17, 2003 PageHistory Info


FL_ONGROUND

Quake Wiki: HomePage FL_ONGROUND

float FL_ONGROUND = 512;

This is a binary ? bitflag ? used for the .flags ? field. When set, many entities cannot move via their .velocity, it's used to prevent things from landing and sliding around on the floor. See also .groundentity ?.

To unset FL_ONGROUND on an entity use
self .flags ? = self .flags ? - (self .flags ? & ? FL_ONGROUND);

This is the safe way to unset a bitflag ?, if you just blindly subtract it, you may corrupt other flags if it wasn't already set.

View Source of this page Last edited on November 19, 2002 PageHistory Info


Flatten Constant Arithmetic

Quake Wiki: HomePage Flatten Constant Arithmetic

/Oa - Flatten constant arithmetic

This optimization will convert, for example:

self .health = 100 + 1;

to essentially:

self .health = 101;

in the compiled assembly. This is a speed optimization and although it saves statements it tends to generate more pr_globals for the new immediates it generates. (for example in the above example, a new '101' immediate will be created to reference the result). This does not affect decompilation.

View Source of this page Last edited on November 4, 2002 PageHistory Info


Fniggium

Fniggium is a medieval RPG-style Total Conversion of Quake, in development by SeienAbunae. Please visit http://fniggium.actionrealm.com for the official, if not bare, site. You could probably find more info on my modDB profile.

View Source of this page Last edited on March 9, 2003 PageHistory Info


Free Resources

Quake Wiki: HomePage Free Resources

FIXME

See Also

  • Telejano resources http://telejano.berlios.de/wiki3/index.php/TexturesSets
  • Free Game Arts http://www.planetquake.com/gg/
View Source of this page Last edited on November 22, 2002 PageHistory Info


Frika C

Quake Wiki: HomePage Frika C

"FrikaC is an immense schoolgirl with black eyes, light shoulder-length hair and a dark skin tone. This icon's pretty features are highlighted by a preference for apricot clothing. Friends say that this individual is typically quirky and liberal , but even allies will admit that this person can be a bit crabby , tending towards haughty when under stress."

FrikaC's Mods and Sods

My email address is kryten at adelphia dot net. I am not the same person as Kryten from Inside3D, it just so happens we were both fans of Red Dwarf and at one time both chose to be known as Kryten. I changed my name to FrikaC upon entering the Quake community, and Kryten from Inside3D changed his name to Kryxan upon leaving. Previous e-mail addresses were deleted by telefragged because I didn't check my mail for about a month (frikac@tlefragged.com, frikac@inside3d.com) and they overfilled with spam. The frika-c@earthling.net address (which was just a redirection to kryten at adelphia dot net) was cancelled when the service ceased to be free.

View Source of this page Last edited on May 19, 2003 PageHistory Info


FrikaC's Mods and Sods

Quake Wiki: HomePage FrikaC's Mods and Sods

This is just about everything I've ever done for Quake, gathered on one big ass page. Some of it is highly buggy and is only here so that you may learn from it.

  • QCVM
  • EBSP
  • FrikBot X ?
  • Snowed ?
  • STC ?
  • Roids
  • Prydon Gate
  • Murphy's Law
  • QCraft ?
  • Jaws ?
  • TokenQuake ?
  • bigmap
  • Vile
  • FrikQuake ?
  • Reltest ?
  • Star Wars Dogfighter

(I don't need to link to FrikQCC do I?)

View Source of this page Last edited on November 12, 2002 PageHistory Info


Frik QCC

Quake Wiki: HomePage Frik QCC

FrikQCC was started a few months before the Quake engine source was released. It was meant to help me gear up for the engine source, sharpen my C skills and prepare me to work on id's code. Originally based off of fastqcc, it was widely (well among the people at MDQNet) enjoyed for a few months. Then J.P. Grossman released QCCX, back in March 2000. QCCX implemented a ton of neato-whizbang features that I just had to have. I immediately set out to add some of the better stuff from FrikQCC 1.x, such as warnings and some of my own ideas of optimizations to his code. The result was FrikQCC 2.0, which has been updated many times since then. I've started moving away from some of the old QCCX features (for example my Arrays are different, as is the new int type) in an effort to make the code more user friendly.

  • Versions & Changelog
  • Warning and Error Guide
  • Optimizations
  • Other Features
  • Downloads

Next version...

View Source of this page Last edited on November 24, 2002 PageHistory Info


Fuh Quake

Quake Wiki: HomePage Fuh Quake

FuhQuake is a win32/linux quakeworld client that aims to not only to have a plethora of gameplay and console improvements, but to also incorporate stunning visual effects and eyecandy.

http://www.fuhquake.net/

View Source of this page Last edited on February 27, 2003 PageHistory Info


Full Recent Changes

Quake Wiki: HomePage Full Recent Changes

Here's a list of all recently changed pages on this wiki, not just the most recent ones found in RecentChanges. (See RecentEdits for all recent minor edits and changes).

RecentChanges RSS

The most recent major edits during the past 3 days are listed below.

Show all changes for: 1 day 3 days 7 days 30 days 90 days ...

May 19, 2003

  • (diff) Gameplay Tips 10:09 am . . . . . . CheapAlert
  • (diff) FrikaC 6:58 am . . . . . . FrikaC
View Source of this page Last edited on October 29, 2002 PageHistory Info

PHP Warnings

lib/plugin/RecentChanges.php:100: Warning[2]: Cannot add header information - headers already sent by (output started at /home/frikqcc/htdocs/lib/ziplib.php:320)


Full Text Search

Quake Wiki: HomePage Full Text Search

Additional Searches:

Tips

Separate words with a space. All words have to match.
To exclude words from a title search or full text search, prepend a '-'.
Example: 'wiki text -php' looks for all pages containing the words 'wiki' and 'text', but not containing the word 'php'.

View Source of this page Last edited on October 29, 2002 PageHistory Info


Fuzzy Pages

Quake Wiki: HomePage Fuzzy Pages

Additional Searches:

Tips

Separate words with a space. All words have to match.
To exclude words from a title search or full text search, prepend a '-'.
Example: 'wiki text -php' looks for all pages containing the words 'wiki' and 'text', but not containing the word 'php'.

View Source of this page Last edited on October 29, 2002 PageHistory Info


Gameplay Tips

Quake Wiki: HomePage Gameplay Tips

The Rocket Jump: Simply have a Rocket Launcher, armor is favored, aim down, jump, then fire a rocket under to propel yourself a bit more. It is used very often, even I (CheapAlert) use it even when I have 10 health (And I die) :P

Dealing with the Shambler: One of the best ways to deal with the Shambler (big wooly yeti-esh thing that roars) is to strafe into his proximity where he will attempt to claw you, then quickly strafe back. A recommended weapon to use against the shambler is the Super Nailgun. Despite rumors, the Shambler may be immune to the Rocket Launcher but he isn't immune to the Grenade Launcher.

See Also

  • Thresh's Quake Bible
View Source of this page Last edited on May 19, 2003 PageHistory Info


Gleeb

Quake Wiki: HomePage Gleeb

Developer of GQ ? : URLhttp://www.planetquake.com/gzone/gq.shtml

View Source of this page Last edited on October 29, 2002 PageHistory Info


Glossary

Quake Wiki: HomePage Glossary

  • angle vector ?
  • bacon
  • boomstick
  • constant
  • dot product
  • evile
  • immediate
  • QuakeWorld
  • telefrag
  • unit vector
  • velocity vector
View Source of this page Last edited on January 3, 2003 PageHistory Info


GLQuake

Quake Wiki: HomePage GLQuake

GLQuake:

id Software released this hacked version of Quake to work with OpenGL while it was constructing Quake 2. There are quite a few problems and differences that should be noted about GLQuake. First off GLQuake does not support fullbrights - this is a minor visual fault, but remember when working with new textures and graphics to always check to see how it looks in classic software quake as, due to poor error diffusion, your new textures may be bespeckled with fullbrights. GLQuake also doesn't support most sprite modes ?. Although sprites are frowned upon in Quake, as it's considered old tech, modders find sprites incredibly useful for special effects. Thirdly, and not really a problem, GLQuake supports translucent water ?, but you need to use a special version of VIS to have it in your maps.

GLQuake is the base for most modern ports of the Quake engine. Check DarkPlaces and Tenebrae sources for heavily improved code. Check FritzQuake ? and the GQ engine for bug-free enhanced classic GLQuake play. Check Telejano, CheapHack and Tera for eyecandy enhanced GLQuake/TomazQuake code.

View Source of this page Last edited on November 17, 2002 PageHistory Info


Good Style

Quake Wiki: HomePage Good Style

"Young writers often suppose that style is a garnish for the meat of prose, a sauce by which a dull dish is made palatable. Style has no such separate entity; it is nondetachable, unfilterable. The beginner should approach style warily, realizing that it is himself he is approaching, no other; and he should begin by turning resolutely away from all devices that are popularly believed to indicate style--all mannerisms, tricks, adornments. The approach to style is by way of plainness, simplicity, orderliness, sincerity."

--Strunk and White, "The Elements of Style"

And thus an American textbook, typical required reading for 10th-grade English students, unknowingly extols some virtues of WabiSabi

--scummings

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Grenade Launcher

Ammunition used: Rockets ?
Ammunition usage: 1/shot
Shot type: grenade
Damage per shot: up to 120 splash damage
Damage per second (max): 200
Range: 1000 units
Cycle time: 0.6s

Commonly used to spam lower sections of a map in multiplayer deathmatch, the grenade launcher shoots a ... you guessed it - a grenade at an arch, it explodes either after 2.5 seconds of bouncing or lying around or coming in contact with a player or monster while air-borne. The explosion gives off a quite a damaging blast radius.

The Shambler takes half damage from the grenade launcher.

See Also: Weapons

View Source of this page Last edited on December 1, 2002 PageHistory Info


Grunt

Goons with probes inserted into their pleasure centers; wired up so when they kill someone, they get a paroxysms of ecstatsy. In essence, customized serial killers. Easy to kill, and they tote shotgun shells. It's like a little Christmas each time you kill one!

Weapon: Shotgun
Health: 30
Treasure: 5 shells

Tips: Grunts are next to harmless alone, but if in large groups, they can be a problem. They have bad aim if you keep moving, and go down after two well-placed shots from your Shotgun. If you're close enough, don't be afraid to use the Double-Barrelled Shotgun to fell them in one shot. If they're not alone, you may find yourself using a Nailgun. If you spot an unsuspected and alone Grunt, feel free to whack them with your Axe.

Entity name: monster_army ?

See Also: Monsters

View Source of this page Last edited on November 27, 2002 PageHistory Info


Hash Lookup in CopyString

Quake Wiki: HomePage Hash Lookup in CopyString

/Os - Hash lookup in CopyString ?

Using this option avoids duplicate strings in the strofs; another space optimization.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Hazards

  • Lava
  • Slime

Dissolution of Eternity Hazards:

  • Pendulum ?
  • Lightning Shooter ?
  • Lava Nail Shooter ?
  • Buzz Saw ?
  • Earthquake ?
View Source of this page Last edited on November 28, 2002 PageHistory Info


Health

Health boxes are in two types, regular or rotted and each one adds a certain amount of health back to the player. The regular health box adds 25 health while the rotted one only adds 15 health.

See Also: Items

View Source of this page Last edited on November 30, 2002 PageHistory Info


Hell Knight

Another name for the Death Knight.

View Source of this page Last edited on November 23, 2002 PageHistory Info


Home Page

Quake Wiki: HomePage Home Page

Welcome to the Quake Wiki. The new focus of this site, formerly the FrikQCC Wiki, will be to catalog and explain virtually everything to do with Quake 1. From mapping to gameplay tips. If it has to do with Quake 1, it will (eventually) be in here.

All textual information contained on this site is understood to be placed under the GNU Free Documentation License version 1.2 unless otherwise stated and may be distributed, modified, or copied under the terms of that license. Quake is a registered trademark of id Software. All other trademarks are properties of their respective owners.

You are invited to add to or correct the documentation. I ask that when filling in new topics you check other similar topics in the same section and try to emulate the layout.

Quake Gameplay

  • Singleplayer Guide
  • Multiplayer Guide
  • Installing Addons
  • Gameplay Tips

Quake Mapping

  • Mapping Tools
  • Textures
  • Entity Guide
  • Mapping Tutorials
  • Map List
  • Mapping Links

QuakeC / Modding

  • Modding Tools
  • QuakeC Basics
  • Builtin Function List
  • System Globals
  • System Fields
  • QuakeC Tips
  • QuakeC Tutorials
  • Free Resources
  • Mod List

Quake Movies

  • Demo Tools
  • Movie List

Quake Engine Info

  • Engine Getting Started ?
  • Engine and Port List
  • QSG Extensions
  • Engine Tutorials
  • Enhanced Engine Features

Quake Technical

  • Quake Error Guide
  • Console Variables
  • Console Commands
  • Command Line Parameters
  • Quake File Formats
  • Quake Network Messages
  • Quake Font
  • Quake Palette
  • Quake tools

Quake Wiki

  • Glossary
  • Acknowledgements
  • Statistics and Info
  • Site Help
  • Register
  • Preferences
  • Search
  • Discussion
  • Links
View Source of this page Last edited on November 29, 2002 PageHistory Info


Home Page/Talk

Quake Wiki: HomePage Home Page/Talk

Discuss away -- FrikaC

Okay, here's a start: What is this new spaceship mod on Tomaz's site? -- SeienAbunae

Err, mod? It's a game.......... -- FrikaC

He is making it from scratch?! -- SeienAbunae

Yeah -- FrikaC

Cool...new question, can you upload images on Wiki? -- SeienAbunae

Well, yeah, FileUpload, then use a URL reference to link to it. -- Rick

Dang, never saw that :P -- SeienAbunae

View Source of this page Last edited on November 27, 2002 PageHistory Info


How To Use Wiki

Quake Wiki: HomePage How To Use Wiki

"Wiki wiki" means "quick" in Hawai'ian.

All you really need to know is:

  • To edit any page click on the Edit Text link at the bottom of the page. You should do that right now, and read the source code of this page. It will make more sense.
  • You get italics by surrounding words with two single quotes on either side like this.
  • You get bold text by using two underscores on either side.
  • And, bold italics by using both.
  • You get bullets by using an asterisk * at the start of the line.
  • To have plain monospaced font, indent with a space:
 this is a poem for sure
 about monospacing
 i wrote in purple velour
 but couldn't find a rhyme for monospacing
  • You can separate paragraphs with an extra blank line. Example:

I am a paragraph.

I am a paragraph too. We're just very small paragraphs.

  • You can get horizontal rules with four or more dashes like this:
  • To create hyperlinks you just capitalize the words and string them together. Let's say you want to create a page about how Steve Wainstead eats worms. All you have to do is capitalize each word and string them together like this: SteveWainsteadEatsLiveWorms ?. If the page does not exist yet a question mark appears after the link, inviting you to create the page: ThisPageShouldNotExist ?. (And please don't ruin the example by creating one.)
  • To link to pages outside the Wiki, you can just type in the URL and Wiki will link it for you: http://www.nytimes.com/
  • To put images in, just provide the hyperlink in brackets like this: [http://www.yourhost.yourdomain/images/picture.png]. Image URLs not in brackets will just appear as hyperlinks to the image.
  • Now you are ready to begin AddingPages.

A WikiWikiWeb is meant to be fast and easy to edit. It has very simple markup that you can read about in TextFormattingRules.

If you don't like the size of the text editing window you get, you can change it. See UserPreferences.

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Hud Models

Quake Wiki: HomePage Hud Models

HudModels is the ability of Telejano to use images has the entity model and draw then in the 2D surface screen.

Pictures need to be stored in a special folder "pics". But management its very easy. You need to precache the model normally:

precache_model("pics/image.tga");

then you use this model for an entity:

setmodel(self,"pics/image.tga");

and you can now set the location:

org_x = 10; org_z = 32;

setorigin(self, org);

Example:

// This function shows a lifebar of a selected unit, with a inside life quantity
// if the health is below 25z the bar will be red.
// This function will show a unit icon, too.
void () HUD_Stay =
{

local string snetname;
local float HUD_frame;
local float finalx;

if (self.owner.selected != world) {

snetname = self.owner.selected.netname; if (snetname == "Harvester")

setmodel(self, "pics/harv.tga");

else if (snetname == "Apache")

setmodel(self, "pics/apache.tga");

else if (snetname == "Mammoth Tank")

setmodel(self, "pics/htank.tga");

else if (snetname == "Light Tank")

setmodel(self, "pics/tank.tga");

else if (snetname == "Flamer Troop")

setmodel(self, "pics/flame.tga");

else if (snetname == "Light Mech")

setmodel(self, "pics/mech.tga");

else if (snetname == "MLRS")

setmodel(self, "pics/mlrs.tga");

else

setmodel(self, "pics/troop.tga");

//The image is the model you set setmodel(self.turret,"pics/bar.tga");

HUD_frame = floor ((((100 / self.owner.selected.max_health) * self.owner.selected.health) / (100 / 125)));

if (HUD_frame>25)

setmodel(self.turret.turret,"pics/bluebar.tga");

else

setmodel(self.turret.turret,"pics/redbar.tga");

//The x coordinate is the origin_x self.turret.turret.origin_x = HUD_frame - 125;

} else {

//If you don't set the model, hud will disappear
setmodel(self, string_null);
setmodel(self.turret,string_null);
setmodel(self.turret.turret,string_null);

}

self.nextthink = time + 0.1;

if (((self.owner.selected = world) || (self.owner.weapon = IT_SHOTGUN))) {

setmodel(self, string_null);
setmodel(self.turret,string_null);
setmodel(self.turret.turret,string_null);

}

};

//This function spawns the hud trackers, set the original location of stuff
void () Make_HUD =
{

local entity missile,lifebar, lifebar2;

missile = spawn (); missile.owner = self;

missile.nextthink = time + 0.1; missile.think = HUD_Stay;

// Screen (8,16) relative to SouthEst ?
missile.origin_z = 3;
missile.origin_x = 8;
missile.origin_y = 16;

lifebar2 = spawn (); lifebar = spawn ();

lifebar.owner = self;

// Screen (8,0) relative to SouthEst ?

lifebar.origin_z = 3;
lifebar.origin_x = 0;
lifebar.origin_y = 8;
lifebar.classname = "lifebar";

missile.turret = lifebar;

lifebar2.owner = self;

lifebar2.origin_z = 3;
lifebar2.origin_x = 0;
lifebar2.origin_y = lifebar.origin_y;
lifebar2.classname = "lifebar";

lifebar.turret = lifebar2;

};

//The "pics" folder is special, hud models MUST be placed in this folder or will not work.
void () precache_hud = {

precache_model("pics/harv.tga");
precache_model("pics/apache.tga");
precache_model("pics/htank.tga");
precache_model("pics/tank.tga");
precache_model("pics/flame.tga");
precache_model("pics/mech.tga");
precache_model("pics/troop.tga");
precache_model("pics/mlrs.tga");
precache_model("pics/bar.tga");
precache_model("pics/redbar.tga");
precache_model("pics/bluebar.tga");

};

View Source of this page Last edited on November 25, 2002 PageHistory Info


Ice Dagger

Quake Wiki: HomePage Ice Dagger

IceDagger. You're friendly neighborhood coder.
http://www.quakepit.com/icedagger/

View Source of this page Last edited on November 25, 2002 PageHistory Info


Im Unreal

Quake Wiki: HomePage Im Unreal

Hello! This is ImUnreal. I've heard most jokes based on that name, but if you make up a really cool one, please don't tell me. I'm majorily interested in id Softwares games. I've always liked to edit all games I play, and I've edited Quake the most. It will still be the game I edit the most, undependant on how many new games are released. I edit Quake in as many ways I can, even though I'm terrible at most parts. It must be due to my vast interest in different subjects, which leads to the fact that I never learn enough of one subject.

View Source of this page Last edited on November 25, 2002 PageHistory Info


Inside 3 D

Quake Wiki: HomePage Inside 3 D

Inside3D, formerly InsideQC, a great site that started years ago, and has tones of QuakeC tutorials. If you're interested in learning QuakeC, it's an excellent starting point.

http://www.inside3d.com

For some personal help, the Inside3D forums are still buzzing with daily activity:

http://forums.inside3d.com

View Source of this page Last edited on October 30, 2002 PageHistory Info


Installing Addons

Add-ons, more commonly known as mods, usually come in a folder in a zip file. For instance, if you downloaded Prydon Gate, it will come in a folder called "PRYDON". To install this addon, place it in your Quake directory, (so it is alongside the "id1" folder). For instance, if your Quake directory is C:\QUAKE, make it C:\QUAKE\PRYDON.

Congratulations, it has been installed. Now to how to run it. You will either need to use the DOS Prompt ? or the Windows Run ? command, either way run the Quake executable, followed by the -game command-line argument, followed by the folder name. For example:

C:\QUAKE\GLQuake.exe -game prydon

Some addons (read the readme first) may require more memory to be allocated. For this, use the -winmem ? console command in DOSQuake ? and the -heapsize ? command in WinQuake and GLQuake (and all engines based on them).

There is an easier way to run the official mission packs, Scourge of Armagon ? and Dissolution of Eternity ?. They are made by the companies Hipnotic Software ? and Rogue Software ?, respectively. They should come with an upgraded DOSQuake ? executable, but if you have WinQuake or GLQuake or a patched DOSQuake ?, you're fine. For Scourge of Armagon ?, use the command-line parameter "-hipnotic". For Dissolution of Eternity ?, use "-rogue". This way you can have modifications of the official mission packs, which are in turn modifications of Quake. Cool, no?

Installing Maps

To install a user-created map, download it and extract the .BSP ? file. Move into your id1/maps folder, for instance if C:\Quake is your Quake folder, move it to:

C:\Quake\id1\maps

Now, run Quake and use the map console command to switch to that level. For instance if the level was called SM36.BSP, type

map sm36

in the console. Alternatively, you could use the +map command-line argument to run it straight off the command line (be sure to use +skill as well to set the difficulty)

View Source of this page Last edited on November 25, 2002 PageHistory Info


Inter Wiki

Quake Wiki: HomePage Inter Wiki

This wiki supports InterWiki links in a style copied from UseMod: wiki. Links to pages in other wikis can be made without having to know or type the full URLs, for example: MeatBall:InterWiki will link to the page named "InterWiki" at Meatball wiki.

The InterWiki map is taken from the the <verbatim> block in InterWikiMap, but that page must be locked for it to work. This denies a potential hacker the ability to nefariously change every InterWiki link to point to some evil URL. If no map is found in InterWikiMap (or the page is not locked), PhpWiki will fall back to using the file lib/interwiki.map in your phpwiki distribution. The InterWiki map file in use at PhpWiki: can be viewed at http://phpwiki.sf.net/interwiki.map.

The map file is manually updated. It is based upon and periodically synchronized with UseMod's InterMap but it is not quite identical. One notable difference from UseMod: is that PhpWiki supports 'zs' within the URLs in the map--see the entry for RFC for an example of how this works.

Not all of the entries in the InterWikiMap are actual wikis. For example, these are just regular web sites: Dictionary:fungible, JargonFile:Alderson loop, IMDB:Roman Holiday, RFC:2822, and ISBN:020171499X.

The "Category" moniker is a special entry which allows one to link a wiki page to a Category page without creating a back-reference. Thus Category:Category links to the CategoryCategory page, yet this page won't show up in the back-links listing of CategoryCategory.

The term "InterWiki" also refers to a broader concept. See PhpWiki:InterWikiSearch for more links.

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Inter Wiki Map

Quake Wiki: HomePage Inter Wiki Map

The InterWiki map used on this wiki is listed below. The map is taken from the text in the verbatim block below. (But this only works if this page is locked.)

Name | InterWiki Address
AbbeNormal | http://www.ourpla.net/cgi-bin/pikie.cgi?
AcadWiki | http://xarch.tu-graz.ac.at/autocad/wiki/
Acronym | http://www.acronymfinder.com/af-query.asp?String=exact&Acronym=
Advogato | http://www.advogato.org/
AndStuff | http://andstuff.org/wiki.php?
BcWireless | http://www.bcwireless.net/wiki-moinmoin/moin.cgi/
BenefitsWiki | http://www.benefitslink.com/cgi-bin/wiki.cgi?
BridgesWiki | http://c2.com/w2/bridges/
bsdWiki | http://profile.sh/syswiki/index.php?
C2find | http://c2.com/cgi/wiki?FindPage&value=
Category | Category
CLiki | http://www.telent.net/cliki/
CmWiki | http://www.ourpla.net/cgi-bin/wiki.pl?
CreationMatters | http://www.ourpla.net/cgi-bin/wiki.pl?
DejaNews | http://www.deja.com/=dnc/getdoc.xp?AN=
Dictionary | http://www.dictionary.com/cgi-bin/dict.pl?term=
DolphinWiki | http://www.object-arts.com/wiki/html/Dolphin/
DseWiki | http://www.wikiservice.at/dse/wiki.cgi?
EfnetCeeWiki | http://rm-f.net/~jh/c-wiki/moin.cgi/
EfnetCppWiki | http://purl.net/wiki/cpp/
EfnetPythonWiki | http://purl.net/wiki/python/
EfnetXmlWiki | http://purl.net/wiki/xml/
EmacsWiki | http://www.emacswiki.org/cgi-bin/wiki.pl?
Foldoc | http://www.foldoc.org/foldoc/foldoc.cgi?
FoxWiki | http://fox.wikis.com/wc.dll?Wiki~
FreeNetworks | http://www.freenetworks.org/index.cgi/
FreshMeat | http://freshmeat.net/
GoogleGroups | http://groups.google.com/groups?q=
Google | http://www.google.com/search?q=
HammondWiki | http://www.dairiki.org/HammondWiki/index.php3?
IAwiki | http://www.IAwiki.net/
IMDB | http://us.imdb.com/Title?
ISBN | http://www.amazon.com/exec/obidos/ISBN=
JargonFile | http://sunir.org/apps/meta.pl?wiki=JargonFile&redirect=
JiniWiki | http://www.cdegroot.com/cgi-bin/jini?
KnowHow | http://www2.iro.umontreal.ca/~paquetse/cgi-bin/wiki.cgi?
LegoWiki | http://www.object-arts.com/wiki/html/Lego-Robotics/
MbTest | http://www.usemod.com/cgi-bin/mbtest.pl?
MeatBall | http://www.usemod.com/cgi-bin/mb.pl?
MetaWiki | http://sunir.org/apps/meta.pl?
MoinMoin | http://purl.net/wiki/moin/
MuWeb | http://www.dunstable.com/scripts/MuWebWeb?
OrgPatterns | http://www.bell-labs.com/cgi-user/OrgPatterns/OrgPatterns?
PersonalTelco | http://www.personaltelco.net/index.cgi/
php-function | http://www.php.net/manual/en/function.zs.php
php-lookup | http://www.php.net/manual-lookup.php?pattern=
PhpWiki | http://phpwiki.sourceforge.net/phpwiki/index.php?
PhpWikiDemo | http://phpwiki.sourceforge.net/demo/
PhpWikiCvs | http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/phpwiki/phpwiki/
Pikie | http://pikie.darktech.org/cgi/pikie?
PolitizenWiki | http://www.politizen.com/wiki.asp?
PPR | http://c2.com/cgi/wiki?
PythonInfo | http://www.python.org/cgi-bin/moinmoin/
PyWiki | http://www.voght.com/cgi-bin/pywiki?
RFC | http://www.faqs.org/rfcs/rfczs.html
SeattleWireless | http://seattlewireless.net/?
SenseisLibrary | http://senseis.xmp.net/?
SourceForge | http://sourceforge.net/
Squeak | http://minnow.cc.gatech.edu/squeak/
StrikiWiki | http://ch.twi.tudelft.nl/~mostert/striki/teststriki.pl?
Tavi | http://tavi.sourceforge.net/index.php?
Thesaurus | http://www.thesaurus.com/cgi-bin/search?config=roget&words=
Thinki | http://www.thinkware.se/cgi-bin/thinki.cgi/
TWiki | http://twiki.org/cgi-bin/view/
UseMod | http://www.usemod.com/cgi-bin/wiki.pl?
VisualWorks | http://wiki.cs.uiuc.edu/VisualWorks/
Why | http://clublet.com/c/c/why?
Wiki | http://c2.com/cgi/wiki?
WikiPedia | http://www.wikipedia.com/wiki.phtml?title=
ZWiki | http://www.zwiki.org/
Telejano | http://telejano.berlios.de/wiki3/index.php/
UnrealWiki | http://wiki.beyondunreal.com/wiki/index.php/
ConsoleQuake | http://console.quakepit.com/phpwiki/index.php/
modDB | http://mods.moddb.com/
files | http://wiki.quakesrc.org/files/
View Source of this page Last edited on March 16, 2003 PageHistory Info


Items

Quake Wiki: HomePage Items

Original Items:

  • Health
  • Ammo Boxes
  • Mega-Health
  • Quad Damage
  • Biosuit
  • Pentagram of Protection
  • Ring of Shadows
  • Yellow Armor ?
  • Blue Armor ?
  • Red Armor ?

Scourge of Armagon Items:

  • Horn of Conjuring ?
  • Empathy Shield ?
  • The Wet Suit ?

Dissolution of Eternity Items:

  • Anti Grav Belt ?
  • Power Shield ?

(.. yet still incomplete)

View Source of this page Last edited on November 28, 2002 PageHistory Info


Jaws/Talk

Quake Wiki: HomePage Jaws/Talk

Jaws: A cool FrikaC mod. Similar to "it" game. The game is underwater. A player is the "jaw" and others play as swinning mens. As player you need to avoid the dangerous jaw and as jaw you need to attack humans with ferocity. The mod include a big underwater level (a box map), and use the FrikBots ? mainly. A similar mod is Fist Fight ?. Cool jaw model and swinning player model. Cool gameplay.

View Source of this page Last edited on November 13, 2002 PageHistory Info


John Romero

Quake Wiki: HomePage John Romero

John Romero: a programmer with nice hair. Used to work for id software, then screwed up hopelessly at ion storm. I believe he now makes games for palm computers.

View Source of this page Last edited on December 3, 2002 PageHistory Info


Knight

Canned meat. Open 'er up and see if it's still fresh.

Weapon: Sword
Health: 75
Treasure: Nothing

Tips: Knights have a sharp sword and strong arms, but their drawback is that they can't hit you from afar. Feel free to take them out with the Rocket Launcher, Nailgun, or Perforator. Or, if you're close enough, two good spanks from the Double-Barrelled Shotgun will work.

Entity name: monster_knight ?

See Also: Monsters

View Source of this page Last edited on November 25, 2002 PageHistory Info


Lava

Burning liquid hot magma in which anything that enters and stays submerged has a short lifespan from then on. Lava is similar to Slime only it drains more health and at a faster rate so once you're in you better get out as soon as possible. Also note that a Biosuit will not protect you.

See Also: Hazards

View Source of this page Last edited on November 30, 2002 PageHistory Info


Like Pages

Quake Wiki: HomePage Like Pages

LikePages are pages which share an initial or final word with that page. See also Wiki:LikePages and MeatBall:LikePages.

These pages share an initial or final title word with 'PhpWikiAdministration'

  • PhpWiki
  • PhpWikiAdministration
  • PhpWikiAdministration/Remove
  • PhpWikiDocumentation
View Source of this page Last edited on October 29, 2002 PageHistory Info


Link Icons

Quake Wiki: HomePage Link Icons

LinkIcons are an optional new feature of PhpWiki. When activated, icons will be displayed in front of URLs to indicate the type of link.

  • http link
  • generic internet link
  • InterWiki link
  • https link
  • mailto link
  • ftp link
Note
//www.libpng.org/pub/png/png-sitemap.html] image format for smooth rendering on any page color or textured background. Older browsers may not display all the images properly.

Examples

The following examples will display with the above link icons only if the administrator has enabled this feature.

InterWiki links

  • InterWiki link PhpWiki:InterWiki
  • A named InterWiki read WhyWikiWorks at c2.

URLs

  • Email address PhpWiki-talk mailing list
  • Normal http link PhpWiki's Home Page
  • Secure http link PhpWiki's Home Page
  • File transfer ftp://ftp.sourceforge.net/

A generic icon is shown for other less common link types.

  • news://nntp.news.com
  • gopher://gopher.caltech.cmu.edu

LinkIcons will only display when the URL protocol is one which PhpWiki is allowed to link to. The following examples won't show any icons and PhpWiki won't automatically provide double-clickable links either, unless the administrator adds them:

  • bogus://oedipus.nostradamus.com
  • bolo://lgm.cheshire.org

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Links

Quake Wiki: HomePage Links

MAIN LINKS

  • FrikaC's Project Whorehouse
  • Inside3D Tutorials

QUAKE ENGINES

  • TomazQuake
  • DarkPlaces
  • CheapHack
  • Tenebrae
  • Telejano

( please add you quake engine here. or update the link)

QUAKE SITES

  • Inside3d
  • QuakeSRC
  • Anacronox.DE.Quake1
  • Quake.DE
  • AnnhilatorQuakeEditing
  • QEXPO
  • QPlay
  • FuhQuake
  • Besmella-Quake
  • New Quake Central
  • OzQuake - Australia Quake!
  • MWorldd
  • Quake Wiki http://wiki.quakesrc.org/ - HERE!

( please add your quake web page here )

OTHERS ENGINES

  • NeoEngine
  • PolyFighter
  • Game Engine
  • Doomsday
  • UnrealWiki
  • Paragui
  • VTerrain
  • TerrainEngine

(please add you no-quake engine here)

QUAKE Dev SITES

  • CocoT
  • Qbism | Old Qbism
  • Tribal
  • FrikaC
  • Akuma
  • ssj4death
  • Lth
  • Xniper
  • CheapAlert
  • Orbital (no quake related)

GFXSCENE

  • POUET
  • OJuice
  • EmuDek
  • CodePixel
  • Grafx Portal
  • Group GIGA
  • Siggraph-Mexico
  • game resources
  • Oficina Coders
  • Coders Portal
  • Java Gamming
  • Resources Gaming
  • BBOX Colisions
  • Rincon del Programador
  • OpenGL Examples
  • Textures Render Sciencia
  • Papers Standford http://graphics.stanford.edu/papers/title.html
  • Cornel Papers http://www.graphics.cornell.edu/pubs/
  • Papers cwis http://www.cs.kuleuven.ac.be/cwis/research/graphics/CGRG.PUBLICATIONS/
  • Tor Papers http://www.cs.brown.edu/~tor/sig2000.html
  • Tor Papers http://www.cs.brown.edu/~tor/sig2001.html
  • Tor Papers http://www.cs.brown.edu/~tor/sig2002.html
  • Terrain http://www.gamedev.net/opengl/spect.html
  • http://www.gamedev.net
  • Umine
  • Riot BSP tuto
  • Compiler/Scripting - http://dynodonalies.com/tutorials/tutorialpage.htm
  • http://www.eponymous.eclipse.co.uk/csharpfaq.htm
  • OpenSourceSites ?
  • Internet, RPG, etc..

GEEKS FORUMS

  • Vivero
  • Hazte Oir
  • BP.
  • /.
  • Stratos-Ad
  • InforSist
  • ElOTroLado
  • CodePixel

MISC MISC MISC

  • Egora Links
  • Fark News
  • Meme Pool
  • Red Robot
  • JerkCity
  • dIVEnEWS

Artist HomePages ?

  • El Hombre que comia diccionarios
  • Hugo Elias
  • Hugues Hoppe
  • Blazer
  • Ramon Caceres

OTHER WIKIPAGES

  • es.wikipedia.com
  • enciclopedia española
  • UnrealWiki

( please add your wiki here )

View Source of this page Last edited on March 16, 2003 PageHistory Info


Local Menu

Quake Wiki: HomePage Local Menu

Go to LocalMenus

View Source of this page Last edited on November 5, 2002 PageHistory Info


Local Menus

Quake Wiki: HomePage Local Menus

LocalMenus its the ability of Telejano and Nexuiz engines to draw a simple menu, typing-driven, defined by a short list of console vars.

menu_0
represent the menu title
menu_1
its the lable of first option
xmenu_1
its the command of first option

. . .

menu_select
is the index of the selected option
menu_up
change the selected option up
menu_down
change the selected option down
menu_exec
exec the command of the selected option
menu_mode
control to show/hide the menu
menu_image
string of the background image
  • For more advanced console menus, find for BorisU QW262 Console Menus
  • For a LocalMenu tutorial, check QuakeSRC tutorials.
View Source of this page Last edited on November 5, 2002 PageHistory Info


Lord Xanathar

Quake Wiki: HomePage Lord Xanathar

Well greetings

I'm Lord Xanathar just a boy of 17 years living in the Netherlands. my intrest lies in A.I. so i decided to start learning about serveral thing like coding programming and some sort of modding. in the past i created small projects like building villages who create food make birth die ect.ect.ect but they die all the time (hehe the power of programming :) ).

well this web site looks fine for me to start and learn the basics of the howl concept. Qauke 1 is old not so complicated as other games and it does not recuire a über system to compile and run my projects.

i hope you wish me luck and meaby that this communitie is still alive so i can discuse some ideas about A.I. with others.

live long and prosper

View Source of this page Last edited on January 28, 2003 PageHistory Info


Maddes

Quake Wiki: HomePage Maddes

Hi, my name is... :)

Ok, I've been addicted to Quake since it was released here in Germany. Due to time constrains caused by work I'm not so deeply involved into the Quake scene anymore, but what I contributed while I was is available at the [Quake Info Pool.

Regards Maddes

View Source of this page Last edited on November 19, 2002 PageHistory Info


Magic Php Wiki URLs

Quake Wiki: HomePage Magic Php Wiki URLs

About phpwiki: URLs

A special type of URL is available for making links to perform administrative and other special functions in PhpWiki. Here is a brief description of how they work.

The basic syntax of a phpwiki: URL is

  phpwiki:pagename?query-args

If pagename is omitted it defaults to the current page.

Query-args should be a set of parameters in standard HTTP GET format.

The "action=x" parameter should almost always be given. It can be one of browse, diff, edit, viewsource, zip, dumpserial, loadserial, remove, lock, unlock, login, logout, setprefs or save. The default action is browse.

Some of the actions accept other parameters.

FullTextSearch, TitleSearch,
Accepts s=search term, and size=input size.
edit
Accepts version.
remove
Accepts verify.
save
Accepts editversion, minor_edit, and content.
setprefs
Accepts edit_area_width, edit_area_height.

Writing Magic Links in Wiki Pages

A magic link looks like:

  [ text | phpwiki-url ]

The "text |" is optional but usually recommended. If given it will provide the label for the link.

The phpwiki-url is a phpwiki: URL as described above.

Some examples

  [ Edit the SandBox | phpwiki:SandBox?action=edit ]

will generate a link which will take you directly to editing the SandBox, like so: Edit the SandBox.

Other possibilites:

  • Diff the SandBox,
  • Lock the HomePage,
  • Get a Full Zip Dump,
  • Search for Page titles containing 'wiki'

Writing Magic Forms in Wiki Pages

Note: The old syntax for Magic forms is no longer supported. They are superceded by <?plugin-form>s.

If the plugin is called using <?plugin-form instead of <?plugin and the plugin supports searching, then it will be rendered as a form.

size
If given, specifies the size of the input area.
s
Specifies the default value for the input.

Examples:

A search plugin invoked with <?plugin instead of <?plugin-form simply inserts the search results of the plugin:

  <?plugin TitleSearch s=wiki noheader=true ?>

Search results for Page titles containing 'wiki':

  • HowToUseWiki
  • InterWiki
  • InterWikiMap
  • MagicPhpWikiURLs
  • PhpWiki
  • PhpWikiAdministration
  • PhpWikiAdministration/Remove
  • PhpWikiDocumentation
  • WikiPlugin
  • WikiWikiWeb
  <?plugin-form FullTextSearch ?>

gives

While

  <?plugin-form TitleSearch formsize=12 ?>

yields

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Mapping Links

Quake Wiki: HomePage Mapping Links

QMAP

"QMap is your custom Quake mapping forum and rant centre. It's totally driven by the community through it's intergrated messageboards which allow you to inform the mapping community your mapping news and information."

The main news section is located URLhttp://www.qmap.org and the actual maps section : URLhttp://www.qmap.org/qmap.php3

View Source of this page Last edited on December 2, 2002 PageHistory Info


Mapping Tools

  • QE5
  • QuArK
  • WorldCraft
  • GTKRadiant

See Also:

  • Quake tools
View Source of this page Last edited on April 25, 2003 PageHistory Info


Mapping Tutorials

Quake Wiki: HomePage Mapping Tutorials

A good number of tutorials are based around the old favorite WorldCraft. Many parts of Quake, Quake2 and HalfLife tutorials are interchangeable. Because of this I've linked tutorials for all three engines.

Basic and Intermediate Tutorials

"The Forge"

The official site for worldcraft 1.6 It details many things involved in making your own maps for quake1 and/or quake2 using worldcraft. The site includes some sample maps to show how some of the (otherwise abstract) ideas like a switch door or "path_corners" work.

Quake Editing Tips

An older and somewhat short question and answer session with American McGee, Tim Willis, Jim Molinets and a few others. Some of this info is now well known to mappers but there may be a thing or two newer mappers don't know. The info is all very old though. The site is dated September 27, 1996

Rust - Level Design Tutorials

A collection of editing tips and tutorials for games based on a various engines. You may want to check the Quake 2, Halflife, and Generic tutorials. Some bits and pieces from other sections could be helpful as well.

JCH Headquarters Advanced Half-life editing FAQ

Aimed at halflife there are many things that are not useful to the Quake1 mapper. Some of the things are still very useful to the Quake1 mapper. Its easy to fallow "FAQ" setup will answer many of the questions mappers have.

Polygon Reduction Methods

by David Hyde, Mad Dog, and Richard Neff. This is aimed at Quake2 and it is very informative. The screenshots are taken using Quake2's gl_showtris command which Quake1 is lacking. This tutorial is in the Rust Tutorials but the concept is so important its being linked seperately here.

DETAIL VERSUS DESIGN

This is a short editorial by Dave J on when design the overal design of a map is more important then the fine details. He uses Halflife as referance... but there are some cases of detail overpowering design in Quake maps. Since details are often harder on the engine it is extra important to find the right balance for maps designed for Quake use.

View Source of this page Last edited on January 20, 2003 PageHistory Info


Map List

Quake Wiki: HomePage Map List

Due to the (expected) volume, this category is split up as follows:

  • Deathmatch Maps Nums - F ?
  • Deathmatch Maps G - L ?
  • Deathmatch Maps M - R ?
  • Deathmatch Maps S - Z ?
  • Singleplayer Maps Nums - J ?
  • Singleplayer Maps K - Z ?
  • FIXME: Add more

See also:

  • Team Fern
View Source of this page Last edited on November 25, 2002 PageHistory Info


MDQNet

Quake Wiki: HomePage MDQNet

Ahh, MDQNet, how I miss it. Long since defunct. You see, first I was hosted on a short lived site call ZerkWorld, by a friend of a friend, Colonel Zerk. ZerkWorld dumped all these Quake sites he had and focussed on soccer of all things. Anyway, I went to my own space for a time, until a friend from ZerkWorld, jballou, started MDQNet, back in it's day it was a very community driven and high energy site. It was there that the first release of FrikQCC came about. After MDQNet became QuakeMods, then it became dead, Kryten at Inside3D invited me there, and that's where FrikQCC has resided until recently. The move to QuakeSrc is because I'm lazy and and I didn't want to set this script up for myself back on Inside3D. -- FrikaC

View Source of this page Last edited on October 30, 2002 PageHistory Info


Mega-Health

A large health box which adds 100 points to your health. Any health points accumulated over 100 will "bleed away" over time.

View Source of this page Last edited on November 27, 2002 PageHistory Info


MilkShape 3D

Quake Wiki: HomePage MilkShape 3D

Milkshape 3D is a modeling tool for Quake2, Q3A, Unreal Tournament, The Sims, Serious Sam, and many more games.

The cost is 20$USD

http://www.swissquake.ch/chumbalum-soft

View Source of this page Last edited on November 27, 2002 PageHistory Info


Modding Tools

Quake Wiki: HomePage Modding Tools

QuakeC Compilers

  • FrikQCC - great compiler :)
  • QCCX
  • meQCC ? - very nice builtin precompiler
  • ProQCC ? - old, don't use
  • fastqcc - old, don't use
  • QCC - id's original, don't use

QuakeC Editors

  • Notepad
  • TexPad ?
  • CODER4 ?
  • Microsoft Visual Studio ?
  • UltraEdit 32 ?

See Also

  • Quake tools
View Source of this page Last edited on November 22, 2002 PageHistory Info


Mod List

Quake Wiki: HomePage Mod List

  • Prydon Gate
  • Kanada invade USA
  • Avionix
  • WarQraft
  • RuneQuake
  • RuneQuake Advanced
  • Nexuiz(a game)
  • Rocketland
  • FrikaC's Mods and Sods

CheapAlert's mods

  • NerfWar
  • Stalker
  • Squad Warfare
  • MedEvile
  • SEB
  • O_o
  • QTest Mod
  • ShotgunFest

(add your mod here)

Similar pages:

  • Historical Mods, by Tei
  • ModDB
  • Gargoyle Spawning Lair- Lost Mods
  • Quake Terminus
View Source of this page Last edited on May 11, 2003 PageHistory Info


Monsters

Quake Wiki: HomePage Monsters

Monsters:

  • Rottweiler
  • Grunt
  • Enforcer
  • Knight
  • Death Knight
  • Rotfish
  • Zombie
  • Scrag
  • Ogre
  • Spawn
  • Fiend
  • Vore
  • Shambler

Scourge of Armagon Monsters:

  • Centroid ?
  • Gremlin ?

Dissolution of Eternity ? Monsters:

  • Phanton Swordsman ?
  • Electric Eel ?
  • Statue ?
  • Hell Spawn ?
  • Multi-Grenade Ogre ?
  • Wrath ?
  • Overlord ?
  • Guardian ?

-- Fixme: Aren't some of those monsters Bosses? Like the dragon guy? -- SeienAbunae.

-- Fixme: Probably, I just copied them out of the DoE manual. -- Rick.

Bosses:

  • Chthon
  • Shub-Niggurath

Scourge of Armagon Bosses:

  • Armagon ?
View Source of this page Last edited on November 25, 2002 PageHistory Info


More About Mechanics

Quake Wiki: HomePage More About Mechanics

PhpWiki is written in the server-side scripting language PHP, available from http://www.php.net/. PHP resembles C and Perl in its syntax, and functions much like ASP, EmbPerl or JSP.

PhpWiki consists of a dozen or so files of mixed PHP and HTML. The web pages that make up a WikiWikiWeb based on PHP live in a DBM file with backup copies of previous versions of pages stored in a second DBM file.

Every time a user hits the site the page requested is pulled from the DBM and rendered on the fly. The user only ever requests the file index.php, which then decides which other php files to include.

Links to pages in the wiki are automatically linked: PhpWiki. This might be the single most compelling aspect of a wiki, the ability to add pages simply by linking to them. The next most compelling thing is how easily external URL's link like this:

  1. http://www.wcsb.org/
  2. ftp://ftp.redhat.com/
  3. news://news.mozilla.org/
  4. http://www.slashdot.com/
  5. http://theregister.co.uk/

Combined with one namespace and a simple markup, a Wiki exhibits many of the characteristics of WabiSabi.

PhpWiki is licensed under the Gnu General Public license, which you should be able to see here: http://www.gnu.org/copyleft/gpl.txt.

PhpWikiDocumentation

View Source of this page Last edited on October 29, 2002 PageHistory Info


Most Popular

Quake Wiki: HomePage Most Popular

The 20 most popular pages of this wiki:
Hits | Page Name
7377 | HomePage
1889 | WinQuake
1692 | RecentChanges
1543 | GLQuake
993 | Engines
948 | SVC_BAD
820 | Quake Font
778 | Quake tools
610 | Farc
597 | WantedPages
543 | FindPage
534 | Modding Tools
513 | FileUpload
503 | Mod List
484 | AllUsers
465 | Singleplayer Guide
460 | FrikQCC
429 | Mapping Tools
411 | Monsters
404 | Installing Addons
View Source of this page Last edited on October 29, 2002 PageHistory Info


MOVETYPE_BOUNCE

Quake Wiki: HomePage MOVETYPE_BOUNCE

float MOVETYPE_BOUNCE = 10;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: Yes
Move while FL_ONGROUND: Yes?

This is a value for the .movetype field. When colliding with another entity or world this entity will rebound like it's made of rubber. Used for gibs and grenades in the original code.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_BOUNCEMISSILE

Quake Wiki: HomePage MOVETYPE_BOUNCEMISSILE

float MOVETYPE_FLYMISSILE = 11;

Disabled in the original engines. Like MOVETYPE_BOUNCE only with the extra size like MOVETYPE_FLYMISSILE. Don't use.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_FLY

Quake Wiki: HomePage MOVETYPE_FLY

float MOVETYPE_FLY = 5;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: No
Move while FL_ONGROUND: No

This is a value for the .movetype field. Entities using this .movetype move around by .velocity and are unaffected by gravity or friction ?. Such an entity only stops if they hit a wall or get the FL_ONGROUND flag.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_FLYMISSILE

Quake Wiki: HomePage MOVETYPE_FLYMISSILE

float MOVETYPE_FLYMISSILE = 9;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: No
Move while FL_ONGROUND: No

This is a value for the .movetype field. Essentially the same as MOVETYPE_FLY, except the bounding box ? is expanded 15 units on collision checks.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_NOCLIP

Quake Wiki: HomePage MOVETYPE_NOCLIP

float MOVETYPE_NOCLIP = 8;

Collide with world: No
Collide with other ents: No
Affected by gravity: No
Move while FL_ONGROUND: N/A

This is a value for the .movetype field. Entities with this value can move around the level via .velocity, right through solid walls and objects. See the noclip command.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_NONE

Quake Wiki: HomePage MOVETYPE_NONE

float MOVETYPE_NONE = 0;

Collide with world: N/A
Collide with other ents: N/A
Affected by gravity: No
Move while FL_ONGROUND: N/A

This is a value for the .movetype field, it signifies that the entity never moves via the engine's physics. Once spawned, it will hover exactly where it was placed. You can still move the object about manually via the use of setorigin, but .velocity and gravity will have no effect.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_PUSH

Quake Wiki: HomePage MOVETYPE_PUSH

float MOVETYPE_PUSH = 7;

Collide with world: No
Collide with other ents: Yes
Affected by gravity: No
Move while FL_ONGROUND: N/A

This is a value for the .movetype field. Entities using this .movetype are noclip to world and each other, however they can push around most other .solid entities. This is typically used for doors, plats an so on. Entities using this movetype also operate slightly different than normal with regard to their .nextthink (see .ltime ?). In addition, MOVETYPE_PUSH entities get their .blocked function called if they are crushing another entity. MOVETYPE_PUSH is restricted (?) to entities using SOLID_BSP.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_STEP

Quake Wiki: HomePage MOVETYPE_STEP

float MOVETYPE_STEP = 4;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: Yes
Move while FL_ONGROUND: No

This is a value for the .movetype field. It tells the engine that the entity never moves by .velocity unless !(self .flags ? & FL_ONGROUND), in other words, the entity is mid-air. Instead the entity most likely uses movetogoal and walkmove ? to get around.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_TOSS

Quake Wiki: HomePage MOVETYPE_TOSS

float MOVETYPE_TOSS = 6;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: Yes
Move while FL_ONGROUND: No

This is a value for the .movetype field. An entity with it will, if not FL_ONGROUND, move about by .velocity and be affected by gravity until it lands. Once landed the entity will never move again. This is typically used for dead bodies.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MOVETYPE_WALK

Quake Wiki: HomePage MOVETYPE_WALK

float MOVETYPE_WALK = 3;

Collide with world: Yes
Collide with other ents: Yes
Affected by gravity: Yes
Move while FL_ONGROUND: Yes

This is a value for the .movetype field. It can only be applied to client entities, using it on any other entity will cause the game to error with bad movetype 3. This movetype tells the engine that the entity slides around the floor of the map via .velocity and autosteps up (see sv_nostep ?). This is the normal .movetype for players.

View Source of this page Last edited on December 10, 2002 PageHistory Info


Movie List

Quake Wiki: HomePage Movie List

<Tei>Eh!! Please mirror this files has posible. The machinima downloading server is quota limited. Blah is very cool to be unavailable for download!</Tei>

  • Eschaton

    • http://www.strangecompany.org/Eschaton
    • Its really themed in the Lovercraft universe.

  • Blahbalicious

      • http://www.planetquake.com/blah/
      • http://www.machinima.com/displayarticle2.php?article=94
    • comments:
      • VERY FUN!!!

  • Operation Bayshield

    • http://www.machinima.com/displayarticle2.php?article=63

  • netQuake Productions

    • http://gamefiles.blueyonder.co.uk/blueyondergames/trailers/movies/quakeworld/netQuake_Brotherwars.avi
    • http://gamefiles.blueyonder.co.uk/blueyondergames/trailers/movies/quakeworld/netQuake_Overclocked_2-hi.avi
    • Good music, good footage, Impresive.
    • Eh!! the correct name is Telejano, not Telejarno!!
    • More fun than the FDE productions, I think.

  • Others:

    • Torn Appart
    • Monster on Parade
    • http://www.planetquake.com/cineplex -- A very good site, though it has a few dated cdrom.com links.
    • http://www.machinema.com -- Came across it when searching for Blahbalicous ?
    • http://www.planetquake.com/qdq/ -- Home of the Quake done Quick speedrun movies
View Source of this page Last edited on April 29, 2003 PageHistory Info


Mr Gleeb

Quake Wiki: HomePage Mr Gleeb

Just another name for Gleeb. Isn't MrG ?.

View Source of this page Last edited on October 29, 2002 PageHistory Info


MSG_ALL

Quake Wiki: HomePage MSG_ALL

float MSG_ALL = 2;

MSG_ALL ostensibly means "reliable to all clients". The network message being sent it put into every client's buffer and should reliably be recieved.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MSG_BROADCAST

Quake Wiki: HomePage MSG_BROADCAST

float MSG_BROADCAST =0;

MSG_ALL means "unreliable to all clients". The network message being sent it put into every client's buffer and may or may not be recieved depending on network conditions. This is usually used for time sensitive data, if the player is lagging badly the packet might be dropped because by the time the player gets it, it may be already out of date. Examples of messsages that should always be broadcasted are SVC_TEMP_ENTITY ? and SVC_PARTICLE.

View Source of this page Last edited on December 10, 2002 PageHistory Info


MSG_INIT

Quake Wiki: HomePage MSG_INIT

float MSG_INIT = 3;

This message mode writes to the server's 8 kilobyte 'signon' buffer that is sent to each client asa the client connects. Only special one time initialization messages should be sent MSG_INIT. MSG_INIT like the other message modes (MSG_ALL, MSG_ONE, and MSG_BROADCAST) is meant to be used with the Write* builtins (WriteByte, WriteChar, WriteShort ?, WriteLong, WriteCoord ?, WriteAngle, WriteString and WriteEntity ?).

View Source of this page Last edited on November 19, 2002 PageHistory Info


MSG_ONE

Quake Wiki: HomePage MSG_ONE

float MSG_ONE = 1;

MSG_ONE means "reliably to one client". This is very useful. With this you can send messages meant to be broadcasted, such as explosions, lightning, etc, to one client - ever wonder how the TeamFortress spy halucinations were done? That's how. MSG_ONE is a boardcast mode meant to be used with commands such as WriteByte, WriteChar, WriteShort ? and so on. The "one client" to send to is the msg_entity global. For example if you wanted to send a SVC_NOP to other, you'd do this:

msg_entity = other;
WriteByte(MSG_ONE, SVC_NOP);

View Source of this page Last edited on December 10, 2002 PageHistory Info


Multiplayer Guide

  • Maps
  • Weapons
  • Items
  • Hazards

Apollyons Quakeworld for Freshies discusses some advanced aspects of online multiplayer QuakeWorld such as proxies or team communication.

View Source of this page Last edited on January 24, 2003 PageHistory Info


Multiplayer Maps

Quake Wiki: HomePage Multiplayer Maps

Id Deathmatch Maps

  • dm1 ? - Place of Two Deaths
  • dm2 - Claustrophobopolis
  • dm3 - The Abandoned Base
  • dm4 - The Bad Place
  • dm5 ? - The Cistern
  • dm6 ? - The Dark Place

Id Singleplayer Maps with tips for Deathmatch

  • dm-start ? Introduction
  • dm-e1m1 ? The Slipgate Complex
  • dm-e1m2 Castle of the Damned
  • dm-e1m3 ? The Necropolis
  • dm-e1m4 ? The Grisly Grotto
  • dm-e1m5 ? Gloom Keep
  • dm-e1m6 ? The Door to Chthon
  • dm-e1m7 ? The House of Chthon
  • dm-e1m8 ? Ziggurat Vertigo
  • dm-e2m1 ? The Installation
  • dm-e2m2 ? The Ogre Citadel
  • dm-e2m3 ? The Crypt of Decay
  • dm-e2m4 ? The Ebon Fortress
  • dm-e2m5 ? The Wizard's Manse
  • dm-e2m6 ? The Dismal Oubliette
  • dm-e2m7 ? Underearth
  • dm-e3m1 ? Termination Central
  • dm-e3m2 ? Vaults of Zin
  • dm-e3m3 ? The Tomb of Terror
  • dm-e3m4 ? Satan's Dark Delight
  • dm-e3m5 ? Wind Tunnels
  • dm-e3m6 ? Chambers of Torment
  • dm-e3m7 ? The Haunted Halls
  • dm-e4m1 ? The Sewage System
  • dm-e4m2 ? The Tower of Despair
  • dm-e4m3 ? The Elder God Shrine
  • dm-e4m4 ? The Palace of Hate
  • dm-e4m5 ? Hell's Atrium
  • dm-e4m6 ? The Pain Maze
  • dm-e4m7 ? Azure Agony
  • dm-e4m8 ? The Nameless City
  • dm-end ? Shub-Niggurath's Pit

Third Party Deathmatch Maps

  • aerowalk ?
  • amphi ?
  • androm9 ?
  • ultrav ?
  • ztndm3 ?
View Source of this page Last edited on December 27, 2002 PageHistory Info


Multiplication

Quake Wiki: HomePage Multiplication

  • - Multiplication

The * (asterisk) character means multiplication, and I'm sure if you've taken any form of math you know what that means. For example:

5 * 3

Will yield 15. The interesting thing about QuakeC multiplication operator is you can multiply vectors with it.

'1 0.5 2' * 8

Will yield the vector '8 4 16', this is extremely useful, especially paired with a unit vector which enables you to quickly specity the length (speed for a velocity vector), or easily scale any vectory by the amount you need.

You can also do a dot product by multiplying two vectors together.

'20 10 5' * '1 2 3'

Will yield a float 55. See dot product.

View Source of this page Last edited on November 28, 2002 PageHistory Info


Multi Grenades

A Dissolution of Eternity ? weapon, when fired, after a short period of time the grenade will split into five grenades for an increased damage radius.

See Also: Weapons

View Source of this page Last edited on November 25, 2002 PageHistory Info


Murphy's Law

Quake Wiki: HomePage Murphy's Law

See the moddb entry for Murphy's Law: modDB:1020

View Source of this page Last edited on February 16, 2003 PageHistory Info


Nailgun

Ammunition used: Nails ?
Ammunition usage: 1/shot
Shot type: projectile
Damage per shot: 9
Cycle time: 0.2s

A two-barrel dingus that prickles bad guys with armour-piercing darts, technically termed "nails".

An effective rapid-fire weapon, useful for long-range situations when accuracy is the key. It fires projectiles, so remember to lead moving targets.
On the subject of armour piercing, the only weapon that armour has any effect (positive or negative) on is the rocket/grenade launcher vs the Shambler's armour. The nailgun will always deal a total of 9 damage per nail divided between the target's armour and health.

See Also: Weapons

View Source of this page Last edited on December 1, 2002 PageHistory Info


Nehahra

View Source of this page Last edited on November 23, 2002 PageHistory Info


Net Quake

Quake Wiki: HomePage Net Quake

NetQuake. The name the QuakeWorld community assing to the old no-internet-oriented quake engine. Also know as Normal Quake, or only Quake.

View Source of this page Last edited on May 4, 2003 PageHistory Info


New Markup Test Page

Quake Wiki: HomePage New Markup Test Page

New lists: asterisks, hash marks, and ";text:def" (wrong...)

  • bullet
  • l1
    • l2
    • l2
      • l3
  1. one
  2. two
  3. three
Term1

definition1.1

definition1.2

Term2

definition2

Term3

definition3

Term4

definition4

definition4.2

Term5

definition5

Mixed -

  • ul1

    1. ul1-ol1
    2. ul1-ol2
      • ul1-ol2-ul1
      • ul1-ol2-ul2
        • ul1-ol2-ul2-ul1
        • ul1-ol2-ul2-ul2

  • l1

       preformatted text
    • l2

old lists, oddly enough, work fine

  • level 1
  • l1
    • l2
    • l2
      • l3
      • l3
        • l4
      • l3
        • l5
      • l3
  1. one
  2. two
    1. one
    2. two
  • l1
    1. three
    2. four
  • l1
    • l2
    1. one
    2. two
 preformatted text
 some more text
  • l1
    • l2
  1. number
  2. number

this is a plain paragraph

  • bullet

this is a plain paragraph again

  1. number

Link tests

  1. normal: HomePage
  2. in brackets: HomePage -- named: the front page
  3. Link in brackets: http://phpwiki.sourceforge.net/
  4. Link outside brackets: http://phpwiki.sourceforge.net/
  5. Link with Wiki word: http://phpwiki.sourceforge.net/phpwiki/index.php?HomePage
  6. Two consecutive links: http://phpwiki.sourceforge.net/ http://phpwiki.sourceforge.net/phpwiki/
  7. PhpWiki on Sourceforge
  8. URL with a WikiWord
  9. Javascript: boo! (is now: named internal link)
  10. A [Link ? produces a Link ?
  11. A Link ? looks like this: [Link ?
  12. This is a zzz ? line break link
  13. Also this page is [not linked to ?, and this one is !NotLinkedTo ? and this one neither !http://not.linked.to/.
    • WikiName ? - WikiNameSameStem ? -- !!WikiName ? - !!WikiNameSameStem ?

    • WikiName ? - !!WikiNameSameStem ? -- WikiName ? - WikiNameSameStem ?

    • WikiNameSameStem ? - WikiName ? -- !!WikiNameSameStem ? - !!WikiName ?

    • WikiNameSameStem ? - !!WikiName ? -- WikiNameSameStem ? - WikiName ?

Markup tests:

underscores for bold

'quotes for bold'

quotes for italic

underscores bold italic

'five quotes bold italic'

six quotes

'Bold italic' and italic (buggy)

'Bold and bold-italic' (also buggy)

h1

h2

h3

this is plain text with

a line break

look at the <a href="http://phpwiki.sourceforge.net/">markup language</a>

you cannot use &, < or >

Usage in preformatted text:

 underscores for bold
 'quotes for bold'
 quotes for italic
 underscores bold italic
 'five quotes bold italic'
 six quotes
 !!! h1
 !! h2
 ! h3
 this is plain text with

 a line break
 look at the <a href="http://phpwiki.sourceforge.net/">markup language</a>
 you cannot use &, < or >
View Source of this page Last edited on October 29, 2002 PageHistory Info


Non Vector Parms

Quake Wiki: HomePage Non Vector Parms

/Op - Non-vector parms

Saves a few cycles by copying non-vector function parameters with a STOREF rather than a STOREV. This is a minor effect, since the only real change takes place in the C code. It doesn't affect decompilability of the mod.

View Source of this page Last edited on October 30, 2002 PageHistory Info


Normal Quake

Quake Wiki: HomePage Normal Quake

Standard Quake engines, like GLQuake, and original md-dos quake.exe file.

Different physics and net-code from QuakeWorld engines. Tons of mods, most of then designed for single player. Work well at LAN and singleplayer, but is better to use QuakeWorld servers/clients for internet play. Anyway some people love to play internet with NQ engines.

View Source of this page Last edited on November 25, 2002 PageHistory Info


Ogre

What's worse than a cannibal monster eight feet tall? One with a chainsaw. And a sackful of grenades.

Weapon: Chainsaw and Grenade Launcher
Health: 200
Treasure: 2 rockets

Tips: Ogres are a common foe in the realms of Quake. With a deadly chainsaw for melee fights and a grenade launcher otherwise, they can truly pack a punch. If you can, get somewhere higher up than they are, because they have trouble aiming their grenades upwards and the grenade might bounce back and hit them :) Use a Double-Barrelled Shotgun at close range, 4 shots should put them down. Otherwise, use a Grenade Launcher or a Rocket Launcher.

Entity name: monster_ogre ? or monster_ogre_marksman

See Also: Monsters

View Source of this page Last edited on November 27, 2002 PageHistory Info


Old Style Table Plugin

Quake Wiki: HomePage Old Style Table Plugin

The OldStyleTablePlugin can be used to include tables within a wiki page using the old-style markup syntax for tables.

<?plugin OldStyleTable
||^  *Name*                |v *Cost*   |v *Notes*
| *First*     | *Last*
|> Jeff       |< Dairiki   |^  Cheap   |< Not worth it
|> Marco      |< Polo      | Cheaper   |< Not available
?>

will get you

Name |  | Cost | Notes
First | Last
Jeff | Dairiki | Cheap | Not worth it
Marco | Polo | Cheaper | Not available

Note that multiple |s lead to spanned columns, and vs can be used to span rows. A > generates a right justified column, < a left justified column and ^ a centered column (which is the default.)

Note that within each table cell, new-style markup is used. You can only use inline markup --- no block level markup is allowed within table cells.

(Using old-style markup wouldn't make much sense, since one can't include multi-line plugin invocations using the old-style markup rules.)

View Source of this page Last edited on September 17, 2002 PageHistory Info


Optimizations

Quake Wiki: HomePage Optimizations

Optimizations can speed up the execution of QuakeC code, or make the progs.dat file smaller, or both.

When used with no command line options, FrikQCC will produce approximately the same progs.dat as the original id QCC (except if any QCCX or FrikQCC specific are used, in which case QCC could never compile it).

Each optimization can be enabled individually, by specifying it on the command line or you can use two pre-sets:

Note the names of optimizations use the letter O and not the numeral 0. Case is sensitive aswell, ie the compiler will ignore /o2.

  • /O2 will enable most of the below optimizations opting for the greatest space savings.
  • /O1 will enable most of the below optimizations but will sacrifice space for greater runtime speed.
  • /Ot - Eliminate Temporary Variables
  • /Oi - Shorten ifs
  • /Op - Non Vector Parms
  • /Oc - Eliminate Constant Names and Defs
  • /Od - Eliminate Duplicate Defs
  • /Os - Hash Lookup in CopyString
  • /Ol - Eliminate Local Names
  • /On - Eliminate Uneeded Function Names
  • /Of - Eliminate Source Code Filenames
  • /Oo - Add Logical Jumps
  • /Oa - Flatten Constant Arithmetic
  • /Or - Recycle temps

More About

  • QuakeC Code Optimizations
View Source of this page Last edited on October 31, 2002 PageHistory Info


Orphaned Pages

Quake Wiki: HomePage Orphaned Pages

OrphanedPages are those pages which don't have any links to them.

Orphaned Pages in this wiki (41 total):
Hits | Page Name | Last Modified
39 | Akuma | November 15, 2002 7:46 am
56 | Camper | November 26, 2002 10:16 am
30 | CategoryHomePages | October 29, 2002 2:36 pm
23 | DaZ | April 3, 2003 4:18 am
56 | DrLabman | November 26, 2002 12:15 am
44 | Errorabove | November 28, 2002 4:24 am
28 | ExternalSearch | October 29, 2002 2:36 pm
610 | Farc | April 12, 2003 10:33 pm
39 | Hell Knight | November 23, 2002 4:06 pm
61 | IceDagger | November 25, 2002 1:32 am
73 | ImUnreal | November 25, 2002 3:54 am
25 | Jaws/Talk | November 13, 2002 4:21 am
40 | Lord Xanathar | January 28, 2003 9:21 am
78 | Maddes | November 19, 2002 2:25 pm
35 | MrGleeb | October 29, 2002 10:03 pm
18 | NetQuake | May 4, 2003 11:24 am
40 | NewMarkupTestPage | October 29, 2002 2:36 pm
30 | OldStyleTablePlugin | September 17, 2002 2:48 pm
36 | PageInfo | October 29, 2002 2:36 pm
34 | Perforator | November 23, 2002 4:10 pm
54 | PgsrcTranslation | October 29, 2002 2:36 pm
78 | PhpWikiAdministration/Remove | October 29, 2002 2:36 pm
14 | QuakeEd | April 25, 2003 9:17 pm
52 | Renegade | November 24, 2002 1:04 am
63 | StaticFiend | November 25, 2002 4:12 am
34 | TranscludePlugin | September 17, 2002 3:03 pm
49 | WarQraft/Talk | November 18, 2002 4:46 am
46 | acous | November 28, 2002 4:53 pm
43 | cdrom.com | January 2, 2003 8:38 pm
58 | chasin | November 25, 2002 10:45 am
68 | cobalt | November 24, 2002 11:33 am
88 | diGGer | March 2, 2003 5:11 pm
23 | drogg | March 23, 2003 10:46 am
4 | frightfan | May 10, 2003 11:05 pm
75 | hexed | December 13, 2002 10:02 am
45 | js | November 25, 2002 8:35 am
39 | pencechp | November 27, 2002 6:23 pm
2 | rocketman | May 11, 2003 2:47 pm
57 | stef.feola | November 28, 2002 8:43 am
12 | xage | April 23, 2003 4:38 pm
28 | || | November 1, 2002 6:33 pm
View Source of this page Last edited on October 29, 2002 PageHistory Info


Other Features

Quake Wiki: HomePage Other Features

  • FrikQCCwill write an error.log in the source dir of all errors/warnings encountered during the compile.
  • FrikQCCwill wait for any key to be pressed before closing when run with no parameters. (Note: the command line parameters -nopause and -pause can be used to override this behavior, one way or the other) (Also note that Windows doesn't properly support getchar() and will wait for a press of the enter key.)
  • The semicolon on the end of functions is now optional.
  • You can optionally use a more C-stlye function header, for example float main (void) as opposed to float(void) main =. The equal sign is also optional.
  • There's a new type name, int. It still really just a float
  • The keyword "local" is also now optional. "float x;" inside a function is equivalent to the old code "local float x;"
  • Summaries have been disabled so you can see more of the warnings in the cheesy Windows DOS box. I never realized how much that sucked until using Linux. You can re-enable the summaries with the -summary option.
  • JP Grossman's mysterious ^[ operator has been renamed to ~[ to resolve an optable conflict with |=. I doubt anyone even knew ^[ existed (it's a vector version of [, for array access) so I doubt this is much of a hassle.
  • More than 8 parameters are allowed for quakec defined functions.
  • A state ? keyword is supplied to use OP_STATE inside a function. This was done for Nehahra support and I kept it because it was cute.
  • Numerous bugs in QCC, QCCX and fastqcc have been fixed. I won't even begin to try and list them all.
  • FrikQCC has changed many warnings and errors to be much more descriptive It will mention what types were expected in a type mismatch, where original declarations are in some redeclared errors, etc.
  • Variable declarations can be prefixed with the keyword "var" to make sure they are not defined constant, but only assigned an initial value. For example: "var float x = 9;"
  • Variable declarations can be prefixed with the keyword "const ?" to make sure they ARE defined constant. Doing so will make all other definitions assume non constant.
  • Variable declarations can be prefixed with the keyword "nosave ?" to make sure they are not saved to a save game file (DEF_SAVEGLOBAL). Ex: "nosave ? var float r;"
  • FrikQCC can now predict wether an int or float will be needed, and will convert immediates to the appropriate value. Because of this you can use single quoted characters as floats now (previously only available as ints)(example ?). In addition, the z for int is now optional.
View Source of this page Last edited on December 10, 2002 PageHistory Info


Page Group Test

Quake Wiki: HomePage Page Group Test

PageGroupTest is a test of the PageGroup plugin.

Click the first page to start the tour of this experimental plugin.

Table of Contents

PageGroupTestOne PageGroupTestTwo PageGroupTestThree PageGroupTestFour

TODO

Page names currently must be listed one per line. An ordered or unordered list would be better.

For reference, here are all the pages that link to PageGroupTest (note that one is missing):

3 pages link to PageGroupTest:

  • PageGroupTestFour
  • PageGroupTestOne
  • PageGroupTestTwo
View Source of this page Last edited on October 29, 2002 PageHistory Info


Page Group Test Four

Quake Wiki: HomePage Page Group Test Four

So, this is the last page in this page group.

Note that looping of off on this page, so Next: shouldn't show up here but it does because of the bug described in PageGroupTestOne.

PageGroupTest [ Previous: PhpWikiAdministration Next: PageGroupTestTwo ]

PageGroupTest

View Source of this page Last edited on October 29, 2002 PageHistory Info


Page Group Test One

Quake Wiki: HomePage Page Group Test One

Ok, this is page one in this page group.

There is a bug. When looping is true (and it is, but only for this first page--another possible flaw) and if the Contents title is not the first item on the Table of Contents page, and if there are other things on the TOC page after the actual list, then things get screwed up. Note that the Previous: link below should point to the last page. Click Next.

Other pages in this group [ Previous: PhpWikiAdministration Next: PageGroupTestTwo ]

PageGroupTest

View Source of this page Last edited on October 29, 2002 PageHistory Info


Page Group Test Three

Quake Wiki: HomePage Page Group Test Three

You're almost there!

Go! [ Next: PageGroupTestTwo ]

Note that the navigation bar can be anywhere, it doesn't have to be at the bottom or even consistent from page to page. The label can also vary--not sure if this is a good thing. Click Next.

View Source of this page Last edited on October 29, 2002 PageHistory Info


Page Group Test Two

Quake Wiki: HomePage Page Group Test Two

PageGroupTest [ Next: PageGroupTestTwo ]

Welcome to page two.

It would be nice if this plugin would work together with BackLinks, so that it's presence on a page would be detected by the backlink plugin without having to actually add a link to the parent: PageGroupTest.

Click Next.

View Source of this page Last edited on October 29, 2002 PageHistory Info


-

Quake Wiki: HomePage -

- - Subtraction

Subtracts two values. Both operands must be of the same type and must be either float or vector. The returned result is the difference of the two operands.

View Source of this page Last edited on December 10, 2002 PageHistory Info


!

Quake Wiki: HomePage !

! - Logical NOT

Returns a float value: TRUE if the operand to the right of the operator is 0 (FALSE), FALSE if that value is non-zero. The operand can be float, string, vector, entity or a function. In short, anything.

TODO: An example might help here

if (!(self.netname=="king llama"))

sprint(self,"you're not a king llama");

if (self.netname!="king llama")

sprint(self,"you're not a king llama");

if (!self.health) // if self.health == 0

sprint(self,"thou arst dead...");

else

sprint(self,"you can be dead or not"); // self.health!=0 (self.health>0 || self.health<0)

toggledvalue = !toggledvalue; //simple toggle with "!"

View Source of this page Last edited on April 30, 2003 PageHistory Info


!=

Quake Wiki: HomePage !=

!= - Is not equal to?

Returns a float value: TRUE if the values specified on either side of the operator are different, FALSE if they're the same. Both operands must be of the same variable type.

View Source of this page Last edited on December 10, 2002 PageHistory Info


&&

Quake Wiki: HomePage &&

&& - Logical AND

Returns a float value: TRUE if the values specified on either side of the operator are non-zero, FALSE if one is 0 (FALSE). Both operands must be float.

Addendum: Under FrikQCC the entity type is allowed on this operator.

View Source of this page Last edited on December 10, 2002 PageHistory Info


+

Quake Wiki: HomePage +

+ - Addition

Adds two values. Both operands must be of the same type and must be either floats or vectors. The returned result is the sum of the two operands.

View Source of this page Last edited on December 10, 2002 PageHistory Info


+command

Quake Wiki: HomePage +command

Command Line Parameters - +

This commandline parameter tells Quake to automatically run certain Console Commands or set Console Variables upon startup. Simply type the console command preceded by a '+'.

For instance:

quake.exe +map e1m1 +skill 0

Will automatically start map e1m1 on easy skill. Virtually any command is accepted, however due to time it's actually recieved, many will be ignored. See stuffcmds ?.

See also:

  • Console Variables
  • Console Commands
View Source of this page Last edited on November 26, 2002 PageHistory Info


+mlook

Quake Wiki: HomePage +mlook

Enables mouselook mode. While mlook is on, you will be able to freely look around with the mouse. This is very handy.

When bind ? to a key, this will only enable mouselook when that key is pressed down.

If you type it straight in the console, it will, as with all other +/- console commands, stay on indefinitely.

To turn mouselook off, use -mlook.

-- SeienAbunae

View Source of this page Last edited on November 4, 2002 PageHistory Info


.blocked

Quake Wiki: HomePage .blocked

Is this Called when entity is trying to move but cant?

View Source of this page Last edited on November 2, 2002 PageHistory Info


.button 0

Quake Wiki: HomePage .button 0

.button0 sets to not null on client's +attack command, and sets to null (0) on -attack command

View Source of this page Last edited on February 27, 2003 PageHistory Info


.classname

Quake Wiki: HomePage .classname

.string classname;

.classname holds the name of the entity's spawn function ?, the function called when the map loads (after a map, changelevel or restart console command) or when the entities are load ?ed from a savegame.

The .classname is commonly used to identify the type an entity is in the QuakeC, for example much of the code relies on the client entities having a .classname of "player" and although you can change this to anything you wish, much of the code will refuse to treat the entity as a player (he can't activate plats, etc.)

View Source of this page Last edited on December 10, 2002 PageHistory Info


.colormap

Quake Wiki: HomePage .colormap

.float colormap;

This field is only used for clients and from the sound of it, one would think it has something to do with the colors of the player as set by the color console command. It really doesn't. .colormap is the client number of the client plus one. The reason this exists is to make entities show the correct colors from the scoreboard - it doesn't allow you to read the colors from the scoreboard, merely informs clients what entity corresponds to who's colors. All players have their colormap set when the connect such that their client entity is colored to the colors in their entry in the scoreboard, also dead bodies are assigned their originator's colormap so they appear with colors taken from the scoreboard.

However .colormap is more or less broken in GLQuake, the programmers there took a shortcut and instead of recoloring any entity with .colormap set, they chose only to color the client entities based on their entity number. This is what causes bodies to lose their colors upon death in GLQuake.

See also .team to read the actual player color.

View Source of this page Last edited on January 15, 2003 PageHistory Info


.fixangle

Quake Wiki: HomePage .fixangle

.float fixangle;

This field acts as a flag for clients that when set to TRUE will cause the engine to emit a SVC_SETANGLE forcing the player's view to match the player's current .angles ?, then clear the flag back to 0. This is obviously a hack by the engine programmers, as .angles ? are meant to be seperate and different from the .v_angle.

Although it essentially does the same thing as SVC_SETANGLE, sending network messages from the QuakeC is frowned upon, therefore .fixangle should be the preferred method for changing the client's view direction unless you have some sterling reason not to use it.

View Source of this page Last edited on November 28, 2002 PageHistory Info


.health

Quake Wiki: HomePage .health

Entity's health amount. If self is a client, self.health will be shown on the bottom center of status bar. :) If self.health <= 0 and self is a client, his view angle will change. :)

View Source of this page Last edited on December 1, 2002 PageHistory Info


.model

This attribute store the model name string. Dont change directly the model with that key, use setmodel instead. .modelindex ? and this name need to be syncronized.

View Source of this page Last edited on January 24, 2003 PageHistory Info


.movetype

Quake Wiki: HomePage .movetype

.float movetype;

Determines if the entity can move, and how gravity and collisions will effect the movement. Can be any of the following values: MOVETYPE_NONE, MOVETYPE_WALK, MOVETYPE_STEP, MOVETYPE_FLY, MOVETYPE_TOSS, MOVETYPE_PUSH, MOVETYPE_NOCLIP, MOVETYPE_FLYMISSILE, MOVETYPE_BOUNCE or MOVETYPE_BOUNCEMISSILE.

Only one movetype value can be used on each entity, you cannot do:

self .movetype = MOVETYPE_FLY | MOVETYPE_NOCLIP;

View Source of this page Last edited on December 10, 2002 PageHistory Info


.netname

Quake Wiki: HomePage .netname

.string netname;

This field is only used for clients and tells the QuakeC the player's current name, which is recieved by the server during the signon process and whenever the name command is executed. This is really useful for printing death messages and so on. Keep in mind that since strings are merely pointers to text, you cannot save off the client's netname. For example:

.string backup;

....

if (self.backup != self .netname)
{

bprint ("You changed your name!\n");
self.backup = self .netname;

}

Will print "You changed your name!" once, when backup hasn't been set yet, but after that the pointer, self.backup, will now point to the same location as .netname and the strings will always be the same.

View Source of this page Last edited on November 26, 2002 PageHistory Info


.nextthink

Quake Wiki: HomePage .nextthink

.float nextthink;

This is the time the entity will .think(). If non zero, when time passes or equals to this value, the engine will call the entity's .think function. .nextthink should always be set relative to time and NOT relative to itself:

self .nextthink = self .nextthink + random()*0.5;

is very bad form. (This code appears in monsters.qc). The reason is upon calling the .think, the engine sets self .nextthink to 0, adding relative to that is a big nono, as the result will almost always some time in the past (mere seconds after the game started). What's more the above code may produce a .nextthink of 0, which would cause no .think at all. See this page on this issue. (FIXME: Make local version of that)

The good way:

self .nextthink = time + 0.1 + random()*0.5;

Point Of Interest: sys_ticrate

Generally, .nextthink ought not really ever fall below the ticrate on a dedicated server. If it does, upon calling .think time will not be strictly increasing, nor will the server actually allow that speed up update.

Problems have been noted in the Grappling hook Code for CTF when its .nextthink was set below sys_ticrate, and were corrected when set to equal the ticrate.

Sugguested code:

float sys_ticrate;

void() StartFrame = ... sys_ticrate = cvar ("sys_ticrate");

Then to be used as:

self .nextthink = time + sys_ticrate;

View Source of this page Last edited on November 28, 2002 PageHistory Info


.origin

This key store the location of entity. Dont change directly, use setorigin instead. Server need to make some operations after a origin change.

About BSP models
these models use world origin has is .origin. Use .absmax and .absmin for calculations of REAL origin.
View Source of this page Last edited on January 24, 2003 PageHistory Info


.owner

Quake Wiki: HomePage .owner

The owner of this entity, for example a rocket or other projectile is owned by the player or monster who fired it, things with an owner can not collide with their owner, nor can their owner collide with them (this can be useful for many things, for example mods with pet shamblers often allow their owner to walk through the pet), this also applies to traceline regarding the forent entity parameter.

View Source of this page Last edited on April 17, 2003 PageHistory Info


.skin

Quake Wiki: HomePage .skin

The number of entity's skin group. If .skin is bigger than entity's skin group number, using first(0) skin group. If skin group has more than 1 texture, it is animated (looped texture changing).

View Source of this page Last edited on December 1, 2002 PageHistory Info


.solid

Quake Wiki: HomePage .solid

.solid determines how other entity's interact with this entity, it can be any of the following: SOLID_NOT SOLID_TRIGGER SOLID_BBOX SOLID_SLIDEBOX SOLID_BSP

By default .solid is SOLID_NOT.

View Source of this page Last edited on April 17, 2003 PageHistory Info


.team

Quake Wiki: HomePage .team

.float team;

This is set for each client to the client's pants color. The id QuakeC uses this, when teamplay is set to decide who is on what team. All players with the same pants color, and therefore .team are considered on the same team.

You may want to decide teams other ways, so you must create a new field - using this field will cause the engine to overwrite it with a new value every time the client changes color.

View Source of this page Last edited on November 30, 2002 PageHistory Info


.think

Quake Wiki: HomePage .think

.void{} think;

The .think field points to a function, that when set, is called when self .nextthink <= time. self is the entity thinking.

example:

self .think = something; //(pointer to)function to call
self .nextthink = time + 0.3; //after 0.3 sec something will be called

View Source of this page Last edited on November 10, 2002 PageHistory Info


.touch

Quake Wiki: HomePage .touch

.void() .touch;

If two entity's touch for some reason (one of them was moving, or one of them is SOLID_TRIGGER), this function is called (with self and other properly set), in such events both entity's .touch functions are called.

If .touch is not set on self, it is not called for self.

A common example is that a rocket (like most projectiles) has a .touch function that causes it to explode.

Note that other can be world, many projectiles do something (playing a bounce sound, exploding, etc) when they hit world or any other SOLID_BSP entity.

See also bounding box ? for special notes on quake restrictions.

View Source of this page Last edited on April 17, 2003 PageHistory Info


.use

Quake Wiki: HomePage .use

.void() use;

Why is this a system field? There's no real reason! It's not used by the engine at all, but it does play a rather central role in some of the QuakeC. (Strictly internal QuakeC variables, don't need to be part of the system area, but this one is). id's QuakeC uses the .use field for doors, triggers, buttons and plats to point a function that will be called when it's triggered. The callling of .use occurs when an entity .target ?ing something fires, SUB_UseTargets in subs.qc looks for all matching .targetname ?s and runs their .use functions. SUB_UseTargets sets self to the new triggered entity and other to the calling entity.

View Source of this page Last edited on October 31, 2002 PageHistory Info


.v_angle

Quake Wiki: HomePage .v_angle

.vector v_angle;

.v_angle is an angle vector ? set for all clients to a rough figure of the client's viewing direction. Rough, because like WriteAngle, the client communicates back the angle as 0-255. The .v_angle is as precise as you can get to where the client's view is pointing. There are some interesting points to note however:

The .v_angle_x, pitch, is flipped. To get the correct value, multiply by -1. The .angles ?_x is about one third this value, so a player looking down at the floor doesn't look like he's laying on the floor.

The .v_angle_y, yaw direction always corresponds to .angles_y, that is the engine updates the angle of the player's model's yaw with the viewing angle.

The .v_angle_z is almost always zero, as players don't roll around....

See also

  • .angles ?
  • .fixangle
View Source of this page Last edited on November 28, 2002 PageHistory Info


.velocity

Quake Wiki: HomePage .velocity

.vector velocity;

This is a velocity vector, meaning it is scaled by frametime then added to the entities .origin each frame for the most basic .movetype, MOVETYPE_NOCLIP. _z is up and down in the game world, and as such the QuakeC gives a player 270 to his .velocity_z when he +jump ?s (see client.qc).

For MOVETYPE_NONE, .velocity is ignored.

For MOVETYPE_FLY and MOVETYPE_STEP, .velocity is ignored if the entity's .flags ? has the FL_ONGROUND bit set.

View Source of this page Last edited on December 9, 2002 PageHistory Info


.weaponframe

Quake Wiki: HomePage .weaponframe

The frame of player weapon view model, defined in .weaponmodel ? Works like .frame ?

View Source of this page Last edited on December 13, 2002 PageHistory Info


<

Quake Wiki: HomePage <

< - Less than

Returns a float value: TRUE if the right operand has a higher value than the left operand, FALSE if the left operand is greater than or equal. Both operands must be float.

View Source of this page Last edited on December 10, 2002 PageHistory Info


<=

Quake Wiki: HomePage <=

<= - Less than or equal to

Returns a float value: TRUE if the right operand has a higher value than, or is equal to the left operand, FALSE if the left operand is greater than the right. Both operands must be float.

View Source of this page Last edited on December 10, 2002 PageHistory Info


=

Quake Wiki: HomePage =

= - Assignment

Stores the value of the right operand into the variable supplied as the left operand. If the left operand is not a variable, you will recieve an Assignment to constant error.

View Source of this page Last edited on November 1, 2002 PageHistory Info


==

Quake Wiki: HomePage ==

== - Is equal to?

Returns a float value: TRUE if the values specified on either side of the operator are the same, FALSE if they differ. Both operands must be of the same variable type. Often used to check the value of a variable.

View Source of this page Last edited on December 10, 2002 PageHistory Info


>

Quake Wiki: HomePage >

> - Greater than

Returns a float value: TRUE if the left operand has a higher value than the right operand, FALSE if the left operand is less than or equal. Both operands must be float.

View Source of this page Last edited on December 10, 2002 PageHistory Info


>=

Quake Wiki: HomePage >=

>= - Greater than or equal to

Returns a float value: TRUE if the left operand has a higher value than, or is equal to the right operand, FALSE if the right operand is greater than the left. Both operands must be float.

View Source of this page Last edited on December 10, 2002 PageHistory Info


-allow 360

Quake Wiki: HomePage -allow 360

Command Line Parameters - -allow360

Versions: WinQuake

Adds 360 pixel wide video modes (if available) to the video configuration menu.

View Source of this page Last edited on November 19, 2002 PageHistory Info


-basedir

Quake Wiki: HomePage -basedir

-basedir is used to change the base directory (/quake/id1) to another directory. For use with a full conversion mod (everything replaced).

View Source of this page Last edited on November 25, 2002 PageHistory Info


-cachedir

Quake Wiki: HomePage -cachedir

Command Line Parameters - -cachedir

Format: -cachedir <path>
Versions: NormalQuake

This parameter specifies the directory path to be used for caching files, this feature was used for remote game development via ISDN, the game would copy the requested files to a local location (such as a hard drive) specified by -cachedir, rather continually accessing the files over the network connection. Use "-cachedir -" to disable caching.

Since most Quake players now keep the entire game locally, there's no reason to use this parameter.

-- SeienAbunae: fixed type (-chachedir) :P

View Source of this page Last edited on November 23, 2002 PageHistory Info


-conheight

Quake Wiki: HomePage -conheight

-conheight works like -height but for the console. With this you can have large text like when using screen res 640x480 in 1600x1200. Used in conjunction with -conwidth.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-conwidth

Quake Wiki: HomePage -conwidth

-conwidth works like -width but for the console. With this you can have large text like when using screen res 640x480 in 1600x1200. Used in conjunction with -conheight.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-current

Quake Wiki: HomePage -current

-current makes quake use current desktop resolution as game width and height instead of default resolution. It uses desktop dimensions but not desktop color depth. Color depth must be set individualy with -bpp switch.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-dedicated

Quake Wiki: HomePage -dedicated

-dedicated starts quake as a dedicated server. eg. '-dedicated 16' will start a 16 player server.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-game

Quake Wiki: HomePage -game

-game used to run mods. eg. '-game somemod' where somemod is the directory which the mod is in.

See Also:

  • Installing Addons
View Source of this page Last edited on November 25, 2002 PageHistory Info


-height

Quake Wiki: HomePage -height

You can specify how many pixels high the screen resolution will be by using the command-line parameter -height. Use this along with -width to set resolutions for engines in which you cannot switch resolutions while the program is running (for memory allocating reasons I believe), such as GLQuake.

Example:

glquake.exe -width 800 -height 600 -bpp 32

Will run GLQuake in 800x600 mode in 32-bit color (see -bpp ?).

View Source of this page Last edited on November 23, 2002 PageHistory Info


-hipnotic

The built-in command-line argument to load the Source of Armagon Mission Pack.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-ip

Quake Wiki: HomePage -ip

xxx.xxx.xxx.xxx - Used to set the IP ? that Quake bind ?s to for TCP ? and UDP ? connection ?s. Useful when Quake fails to bind ? to all IP ?s, or the wrong IP ?.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-listen

Quake Wiki: HomePage -listen

-listen used to start a listen server. This is similar to dedicated but someone can play on the server. Usage: '-listen 16' starts a 16 player listen server.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-mlook

Quake Wiki: HomePage -mlook

Disables +mlook.

-- SeienAbunae

View Source of this page Last edited on November 4, 2002 PageHistory Info


-nocdaudio
This option will disable the audio cd initialization (mmsystem on windows) during program start.
As a result, no cd music is available during the game.

View Source of this page Last edited on February 2, 2003 PageHistory Info


-particles

Quake Wiki: HomePage -particles

Command Line Parameters - -particles

Versions: NormalQuake

This command line option overrides the default maximum number of particles the client can maintain, which is normally 2048. The minimum accepted value is 512. This option is particularly useful when using pointfile to find a leak, as the line it draws is made of particles.

View Source of this page Last edited on December 1, 2002 PageHistory Info


-rogue

Quake Wiki: HomePage -rogue

The built-in command-line argument to load the Dissolution of Eternity ? mission pack.

View Source of this page Last edited on November 25, 2002 PageHistory Info


-width

Quake Wiki: HomePage -width

You can specify how many pixels wide the screen resolution will be by using the command-line parameter -width. Use this along with -height to set resolutions for engines in which you cannot switch resolutions while the program is running (for memory allocating reasons I believe), such as GLQuake.

Example:

glquake.exe -width 800 -height 600 -bpp 32

Will run GLQuake in 800x600 mode in 32-bit color (see -bpp ?).

View Source of this page Last edited on November 23, 2002 PageHistory Info


-window

Quake Wiki: HomePage -window

window mode

View Source of this page Last edited on November 25, 2002 PageHistory Info